EmbedPress < 3.9.2 - Reflected XSS
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The EmbedPress WordPress plugin before 3.9.2 does not sanitise and escape a parameter before outputting it back in the page containing a specific content, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | EmbedPress | before 3.9.2 | 3.9.2 | Patch available | CNA |
- EmbedPress VendorUnknown Affected before 3.9.2 Fixed in 3.9.2 Patch available CNA
Remediation
- Fix · CNA EmbedPress (Unknown) Fixed in 3.9.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
EmbedPress 3.9.2
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2023-05288 EmbedPress < 3.9.2 - Reflected XSSPriority LOW 28
Timeline
- 2026-10-02 Threatist record created from CVE-2023-5750
- 2026-10-03 Alias added: GHSA-cggh-h9pr-g6p6
References
More wpdevteam Embedpress vulnerabilities
- TI-2024-20660 WordPress EmbedPress plugin <= 3.9.8 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-28980 WordPress EmbedPress plugin <= 4.0.9 - Local File Inclusion vulnerability CVSS 3.1CRITICAL 9.8
- TI-2023-03152 EmbedPress <= 3.7.3 - Sensitive Information Exposure CVSS 3.1HIGH 7.5
- TI-2024-25941 WordPress EmbedPress plugin <= 4.0.4 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2023-28033 WordPress EmbedPress plugin <= 3.8.3 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2024-20650 WordPress EmbedPress plugin <= 3.9.11 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.3
Sources
- CVE-2023-5750 · CVE Program
- CVE-2023-5750 · NVD
- FIRST EPSS
- GHSA-cggh-h9pr-g6p6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences