Denial of Service via crashing the Calls Plugin
Priority LOW 21CWE-754Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Mattermost fails to properly validate requests to the Calls plugin, allowing an attacker sending a request without a User Agent header to cause a panic and crash the Calls plugin
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00613 49th percentileScored 2026-11-07
Fix Fixed Mattermost (Mattermost): 8.1.3, 8.0.4, 7.8.12github.com/mattermost/mattermost-server/v6 (Go): 7.8.12+1 more product
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | up to 8.1.2; up to 8.0.3; up to 7.8.11 | 8.1.3, 8.0.4, 7.8.12 | Patch available | CNA |
| — | github.com/mattermost/mattermost-server/v6 (Go) | before 7.8.12 | 7.8.12 | Patch available | GHSA-xvq6-h898-wcj8 |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 8.0.0 to before 8.0.4 | 8.0.4 | Patch available | GHSA-xvq6-h898-wcj8 |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 8.1.0 to before 8.1.3 | 8.1.3 | Patch available | GHSA-xvq6-h898-wcj8 |
| — | github.com/mattermost/mattermost/server/v8 (Go) | 9.0.0 to before 9.0.1 | 9.0.1 | Patch available | GHSA-xvq6-h898-wcj8 |
- Mattermost VendorMattermost Affected up to 8.1.2; up to 8.0.3; up to 7.8.11 Fixed in 8.1.3, 8.0.4, 7.8.12 Patch available CNA
- github.com/mattermost/mattermost-server/v6 (Go) Vendor— Affected before 7.8.12 Fixed in 7.8.12 Patch available GHSA-xvq6-h898-wcj8
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 8.0.0 to before 8.0.4 Fixed in 8.0.4 Patch available GHSA-xvq6-h898-wcj8
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 8.1.0 to before 8.1.3 Fixed in 8.1.3 Patch available GHSA-xvq6-h898-wcj8
- github.com/mattermost/mattermost/server/v8 (Go) Vendor— Affected 9.0.0 to before 9.0.1 Fixed in 9.0.1 Patch available GHSA-xvq6-h898-wcj8
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost:*:*:*:*:*:*:*:* | up to 7.8.11; 8.0.0 – 8.0.3; 8.1.0 – 8.1.2 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost:*:*:*:*:*:*:*:* Versions up to 7.8.11; 8.0.0 – 8.0.3; 8.1.0 – 8.1.2 Vulnerable ·Mattermost
Remediation
- Fix · CNA Mattermost (Mattermost) Fixed in 8.1.3, 8.0.4, 7.8.12
- Fix · GHSA-xvq6-h898-wcj8 github.com/mattermost/mattermost-server/v6 (Go) Fixed in 7.8.12 Advisory →
- Fix · GHSA-xvq6-h898-wcj8 github.com/mattermost/mattermost/server/v8 (Go) Fixed in 8.0.4 Advisory →
- Fix · GHSA-xvq6-h898-wcj8 github.com/mattermost/mattermost/server/v8 (Go) Fixed in 8.1.3 Advisory →
- Fix · GHSA-xvq6-h898-wcj8 github.com/mattermost/mattermost/server/v8 (Go) Fixed in 9.0.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-5967
- 2026-10-03 Alias added: GHSA-xvq6-h898-wcj8
References
More Mattermost vulnerabilities
- TI-2024-26695 Malicious remote can invite itself to an arbitrary local channel CVSS 3.1CRITICAL 9.6
- TI-2023-02056 Oauth authorization codes do not expire when deauthorizing an oauth2 app CVSS 3.1CRITICAL 9.1
- TI-2019-15069 An issue was discovered in Mattermost Mobile Apps before 1.26.0. CVSS 3.1CRITICAL 9.1
- TI-2024-26233 Malicious remote can add users to arbitrary teams and channels CVSS 3.1HIGH 8.7
- TI-2024-26746 Permanently local data deletion by malicious remote CVSS 3.1HIGH 8.7
- TI-2023-06508 Injection in Mattermost CVSS 3.1HIGH 8.8
Sources
- CVE-2023-5967 · CVE Program
- CVE-2023-5967 · NVD
- FIRST EPSS
- GHSA-xvq6-h898-wcj8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences