Html5 Video Player < 2.5.19 - Subscriber+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Html5 Video Player WordPress plugin before 2.5.19 does not sanitise and escape some of its player settings, which combined with missing capability checks around the plugin could allow any authenticated users, such as low as subscribers to perform Stored Cross-Site Scripting attacks against high privilege users like admins
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Html5 Video Player | before 2.5.19 | 2.5.19 | Patch available | CNA |
- Html5 Video Player VendorUnknown Affected before 2.5.19 Fixed in 2.5.19 Patch available CNA
Remediation
- Fix · CNA Html5 Video Player (Unknown) Fixed in 2.5.19
Timeline
- 2026-10-02 Threatist record created from CVE-2023-6485
- 2026-10-03 Alias added: GHSA-p5mw-mg37-2vrh
References
More bPlugins Html5 Video Player vulnerabilities
- TI-2024-05133 HTML5 Video Player < 2.5.27 - Unauthenticated SQLi CVSS 3.1MEDIUM 6.5
- TI-2024-00982 SQL injection in html5-video-player CVSS 3.1CRITICAL 9.8
- TI-2024-28948 WordPress HTML5 Video Player plugin <= 2.5.30 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2024-07162 Missing authorization in bPlugins HTML5 Video Player – Embed and Play Videos in Custom… CVSS 3.1MEDIUM 5.3
- TI-2024-07156 Missing authorization in bPlugins HTML5 Video Player – Embed and Play Videos in Custom… CVSS 3.1MEDIUM 4.3
Sources
- CVE-2023-6485 · CVE Program
- CVE-2023-6485 · NVD
- FIRST EPSS
- GHSA-p5mw-mg37-2vrh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences