Product Enquiry for WooCommerce < 3.1 - Admin+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Product Enquiry for WooCommerce WordPress plugin before 3.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Product Enquiry for WooCommerce | before 3.1 | 3.1 | Patch available | CNA |
- Product Enquiry for WooCommerce VendorUnknown Affected before 3.1 Fixed in 3.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gravitymaster:product_enquiry_for_woocommerce:*:*:*:*:*:wordpress:*:* | before 3.1 | Vulnerable | Gravity Master |
- cpe:2.3:a:gravitymaster:product_enquiry_for_woocommerce:*:*:*:*:*:wordpress:*:* Versions before 3.1 Vulnerable ·Gravity Master
Remediation
- Fix · CNA Product Enquiry for WooCommerce (Unknown) Fixed in 3.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Product Enquiry for WooCommerce 3.1
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2023-06072 Product Enquiry for WooCommerce < 3.1 - Arbitrary Enquiry Deletion via CSRFPriority LOW 19
Timeline
- 2026-10-02 Threatist record created from CVE-2023-6626
- 2026-10-03 Alias added: GHSA-r66j-9v9r-h3h9
References
More Gravity Master Product Enquiry For Woocommerce vulnerabilities
- TI-2023-06539 Product Enquiry for WooCommerce < 3.2 - Reflected XSS CVSS 3.1MEDIUM 6.1
- TI-2023-27171 WordPress Product Enquiry for WooCommerce Plugin <= 3.0 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2023-25833 WordPress Product Enquiry for WooCommerce Plugin <= 3.0 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2023-25683 WordPress Product Enquiry for WooCommerce Plugin <= 3.0 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2023-06072 Product Enquiry for WooCommerce < 3.1 - Arbitrary Enquiry Deletion via CSRF CVSS 3.1MEDIUM 4.3
Sources
- CVE-2023-6626 · CVE Program
- CVE-2023-6626 · NVD
- FIRST EPSS
- GHSA-r66j-9v9r-h3h9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences