Product Enquiry for WooCommerce < 3.2 - Reflected XSS
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Product Enquiry for WooCommerce WordPress plugin before 3.2 does not sanitise and escape the page parameter before outputting it back in an attribute, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0046 40th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Product Enquiry for WooCommerce (Unknown): 3.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Product Enquiry for WooCommerce | before 3.2 | 3.2 | Patch available | CNA |
- Product Enquiry for WooCommerce VendorUnknown Affected before 3.2 Fixed in 3.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gravitymaster:product_enquiry_for_woocommerce:*:*:*:*:*:wordpress:*:* | before 3.2 | Vulnerable | Gravity Master |
- cpe:2.3:a:gravitymaster:product_enquiry_for_woocommerce:*:*:*:*:*:wordpress:*:* Versions before 3.2 Vulnerable ·Gravity Master
Remediation
- Fix · CNA Product Enquiry for WooCommerce (Unknown) Fixed in 3.2
Timeline
- 2026-10-02 Threatist record created from CVE-2023-7151
- 2026-10-03 Alias added: GHSA-mg9f-ffx6-x997
References
More Gravity Master Product Enquiry For Woocommerce vulnerabilities
- TI-2023-06073 Product Enquiry for WooCommerce < 3.1 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2023-27171 WordPress Product Enquiry for WooCommerce Plugin <= 3.0 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2023-25833 WordPress Product Enquiry for WooCommerce Plugin <= 3.0 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2023-25683 WordPress Product Enquiry for WooCommerce Plugin <= 3.0 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2023-06072 Product Enquiry for WooCommerce < 3.1 - Arbitrary Enquiry Deletion via CSRF CVSS 3.1MEDIUM 4.3
Sources
- CVE-2023-7151 · CVE Program
- CVE-2023-7151 · NVD
- FIRST EPSS
- GHSA-mg9f-ffx6-x997 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences