Cross-site scripting in wpdevteam EmbedPress – PDF Embedder, Embed YouTube Videos, 3D…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The EmbedPress – Embed PDF, YouTube, Google Docs, Vimeo, Wistia Videos, Audios, Maps & Any Documents in Gutenberg & Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's embed_oembed_html shortcode in all versions up to 3.9.5 (exclusive) due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| wpdevteam | EmbedPress – PDF Embedder, Embed YouTube Videos, 3D FlipBook, Social feeds, Docs & more | before 3.9.5 | 3.9.5 | Patch available | CNA |
- EmbedPress – PDF Embedder, Embed YouTube Videos, 3D FlipBook, Social feeds, Docs & more Vendorwpdevteam Affected before 3.9.5 Fixed in 3.9.5 Patch available CNA
Remediation
- Fix · CNA EmbedPress – PDF Embedder, Embed YouTube Videos, 3D FlipBook, Social feeds, Docs & more (wpdevteam) Fixed in 3.9.5
Timeline
- 2026-10-02 Threatist record created from CVE-2023-6986
- 2026-10-03 Alias added: GHSA-55rm-p79h-88wj
References
Patch 2
More wpdevteam Embedpress vulnerabilities
- TI-2024-20660 WordPress EmbedPress plugin <= 3.9.8 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-28980 WordPress EmbedPress plugin <= 4.0.9 - Local File Inclusion vulnerability CVSS 3.1CRITICAL 9.8
- TI-2023-03152 EmbedPress <= 3.7.3 - Sensitive Information Exposure CVSS 3.1HIGH 7.5
- TI-2024-25941 WordPress EmbedPress plugin <= 4.0.4 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2023-28033 WordPress EmbedPress plugin <= 3.8.3 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2024-20650 WordPress EmbedPress plugin <= 3.9.11 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.3
Sources
- CVE-2023-6986 · CVE Program
- CVE-2023-6986 · NVD
- FIRST EPSS
- GHSA-55rm-p79h-88wj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences