automad User Creation cross-site request forgery
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
A vulnerability was found in automad up to 1.10.9. It has been rated as problematic. This issue affects some unknown processing of the file /dashboard?controller=UserCollection::createUser of the component User Creation Handler. The manipulation leads to cross-site request forgery. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. The associated identifier of this vulnerability is VDB-248687. NOTE: The vendor was contacted early about this disclosure but did not respond in any way.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | automad | 1.10.0; 1.10.1; 1.10.2; 1.10.3; 1.10.4; 1.10.5; 1.10.6; 1.10.7; 1.10.8; 1.10.9 | — | No fix listed | CNA |
| — | automad/automad (Packagist) | before 2.0.0-alpha.1 | 2.0.0-alpha.1 | Patch available | GHSA-4j8w-p6hv-3qxc |
- automad Vendor— Affected 1.10.0; 1.10.1; 1.10.2; 1.10.3; 1.10.4; 1.10.5; 1.10.6; 1.10.7; 1.10.8; 1.10.9 Fixed in — No fix listed CNA
- automad/automad (Packagist) Vendor— Affected before 2.0.0-alpha.1 Fixed in 2.0.0-alpha.1 Patch available GHSA-4j8w-p6hv-3qxc
Remediation
- Fix · GHSA-4j8w-p6hv-3qxc automad/automad (Packagist) Fixed in 2.0.0-alpha.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-7038
- 2026-10-03 Alias added: GHSA-4j8w-p6hv-3qxc
References
More Automad vulnerabilities
- TI-2024-26904 An arbitrary file upload vulnerability in the image upload function of Automad v2.0.0… CVSS 3.1HIGH 8.8
- TI-2021-15414 Cross Site Scripting (XSS) vulnerability in automad 1.7.5 allows remote attackers to run… CVSS 3.1MEDIUM 5.4
- TI-2024-26872 A persistent (stored) cross-site scripting (XSS) vulnerability has been identified in… CVSS 3.1MEDIUM 4.8
- TI-2023-06433 automad FileController.php import server-side request forgery CVSS 3.1HIGH 8.8
- TI-2022-01408 automad Dashboard cross site scripting CVSS 3.1MEDIUM 5.4
- TI-2023-06432 automad Content Type FileCollectionController.php upload unrestricted upload CVSS 3.1MEDIUM 5.4
Sources
- CVE-2023-7038 · CVE Program
- CVE-2023-7038 · NVD
- FIRST EPSS
- GHSA-4j8w-p6hv-3qxc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences