An arbitrary file upload vulnerability in the image upload function of Automad v2.0.0…
Priority HIGH 73CWE-434Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-434.
Summary
An arbitrary file upload vulnerability in the image upload function of Automad v2.0.0 allows attackers to execute arbitrary code via a crafted file.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00812 57th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed automad/automad (Packagist): 2.0.0-alpha.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | automad/automad (Packagist) | before 2.0.0-alpha.5 | 2.0.0-alpha.5 | Patch available | GHSA-47mc-qmh2-mqj4 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- automad/automad (Packagist) Vendor— Affected before 2.0.0-alpha.5 Fixed in 2.0.0-alpha.5 Patch available GHSA-47mc-qmh2-mqj4
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:automad:automad:*:*:*:*:*:*:*:* | up to 1.10.9 | Vulnerable | Automad |
| cpe:2.3:a:automad:automad:2.0.0:alpha1:*:*:*:*:*:* | 2.0.0 alpha1 | Vulnerable | Automad |
| cpe:2.3:a:automad:automad:2.0.0:alpha2:*:*:*:*:*:* | 2.0.0 alpha2 | Vulnerable | Automad |
| cpe:2.3:a:automad:automad:2.0.0:alpha3:*:*:*:*:*:* | 2.0.0 alpha3 | Vulnerable | Automad |
| cpe:2.3:a:automad:automad:2.0.0:alpha4:*:*:*:*:*:* | 2.0.0 alpha4 | Vulnerable | Automad |
- cpe:2.3:a:automad:automad:*:*:*:*:*:*:*:* Versions up to 1.10.9 Vulnerable ·Automad
- cpe:2.3:a:automad:automad:2.0.0:alpha1:*:*:*:*:*:* Versions 2.0.0 alpha1 Vulnerable ·Automad
- cpe:2.3:a:automad:automad:2.0.0:alpha2:*:*:*:*:*:* Versions 2.0.0 alpha2 Vulnerable ·Automad
- cpe:2.3:a:automad:automad:2.0.0:alpha3:*:*:*:*:*:* Versions 2.0.0 alpha3 Vulnerable ·Automad
- cpe:2.3:a:automad:automad:2.0.0:alpha4:*:*:*:*:*:* Versions 2.0.0 alpha4 Vulnerable ·Automad
Remediation
- Fix · GHSA-47mc-qmh2-mqj4 automad/automad (Packagist) Fixed in 2.0.0-alpha.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-40400
- 2026-10-03 Alias added: GHSA-47mc-qmh2-mqj4
References
More Automad vulnerabilities
- TI-2021-15414 Cross Site Scripting (XSS) vulnerability in automad 1.7.5 allows remote attackers to run… CVSS 3.1MEDIUM 5.4
- TI-2024-26872 A persistent (stored) cross-site scripting (XSS) vulnerability has been identified in… CVSS 3.1MEDIUM 4.8
- TI-2023-06433 automad FileController.php import server-side request forgery CVSS 3.1HIGH 8.8
- TI-2023-06434 automad User Creation cross-site request forgery CVSS 3.1MEDIUM 6.5
- TI-2022-01408 automad Dashboard cross site scripting CVSS 3.1MEDIUM 5.4
- TI-2023-06432 automad Content Type FileCollectionController.php upload unrestricted upload CVSS 3.1MEDIUM 5.4
Sources
- CVE-2024-40400 · CVE Program
- CVE-2024-40400 · NVD
- FIRST EPSS
- GHSA-47mc-qmh2-mqj4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences