Community by PeepSo < 6.3.1.2 - User Post Creation via CSRF
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-352.
Summary
The Community by PeepSo WordPress plugin before 6.3.1.2 does not have CSRF check when creating a user post (visible on their wall in their profile page), which could allow attackers to make logged in users perform such action via a CSRF attack
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Community by PeepSo | before 6.3.1.2 | 6.3.1.2 | Patch available | CNA |
- Community by PeepSo VendorUnknown Affected before 6.3.1.2 Fixed in 6.3.1.2 Patch available CNA
Remediation
- Fix · CNA Community by PeepSo (Unknown) Fixed in 6.3.1.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Community by PeepSo 6.3.1.2
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2024-00169 Community by PeepSo < 6.3.1.2 - Reflected XSSPriority MEDIUM 60
Timeline
- 2026-10-02 Threatist record created from CVE-2023-7125
- 2026-10-03 Alias added: GHSA-37m7-jq3g-46vx
References
More Peepso vulnerabilities
- TI-2024-00169 Community by PeepSo < 6.3.1.2 - Reflected XSS CVSS 3.1MEDIUM 6.1
- TI-2016-09006 The peepso-core plugin before 1.6.1 for WordPress has PeepSoProfilePreferencesAjax->save() privilege escalation. CVSS 3.1HIGH 8.8
- TI-2023-15395 WordPress Community by PeepSo Plugin <= 6.0.9.0 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2023-20824 WordPress Community by PeepSo Plugin <= 6.1.6.0 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2023-11212 WordPress Community by PeepSo Plugin <= 6.0.2.0 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2022-20031 WordPress Community by PeepSo Plugin <= 6.0.2.0 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
Sources
- CVE-2023-7125 · CVE Program
- CVE-2023-7125 · NVD
- FIRST EPSS
- GHSA-37m7-jq3g-46vx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences