Priority MEDIUM 60
The Community by PeepSo WordPress plugin before 6.3.1.2 does not sanitise and escape various parameters and generated URLs before outputting them back attributes, leading to a Reflected Cross-Site Scripting which could b…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00515 · Published 2024-01-16 · Fixed in 6.3.1.2 CWE-79
Priority MEDIUM 41
The peepso-core plugin before 1.6.1 for WordPress has PeepSoProfilePreferencesAjax->save() privilege escalation.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.01576 · Published 2019-09-16 · No fix listed CWE-269
Priority MEDIUM 40
Cross-Site Request Forgery (CSRF) vulnerability in PeepSo Community by PeepSo – Social Network, Membership, Registration, User Profiles plugin <= 6.0.9.0 versions.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00328 · Published 2023-11-09 · No fix listed CWE-352
Priority LOW 38
Cross-Site Request Forgery (CSRF) vulnerability in PeepSo Download Community by PeepSo plugin <= 6.1.6.0 versions.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00254 · Published 2023-11-22 · No fix listed CWE-352
Priority LOW 38
Cross-Site Request Forgery (CSRF) vulnerability in PeepSo Community by PeepSo plugin <= 6.0.2.0 versions.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00256 · Published 2023-05-03 · No fix listed CWE-352
Priority LOW 38
Cross-Site Request Forgery (CSRF) vulnerability in PeepSo Community by PeepSo – Social Network, Membership, Registration, User Profiles plugin <= 6.0.2.0 versions.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00248 · Published 2023-04-04 · No fix listed CWE-352
Priority LOW 37
Subscriber SQL Injection in Community by PeepSo <= 9.0.5.2 versions.
CVSS 3.1HIGH 8.5· Network · Low privileges · No interaction · EPSS 0.00357 · Published 2026-08-19 · No fix listed CWE-89
Priority LOW 34
Subscriber Arbitrary File Deletion in PeepSo <= 9.0.5.4 versions.
CVSS 3.1HIGH 7.7· Network · Low privileges · No interaction · EPSS 0.00437 · Published 2026-10-10 · No fix listed CWE-22
Priority LOW 34
The PeepSo Core: Groups plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Group Description field in all versions up to, and including, 6.4.6.0 due to insufficient input sanitization and output es…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00244 · Published 2025-07-03 · No fix listed CWE-79
Priority LOW 31
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in PeepSo Community by PeepSo – Social Network, Membership, Registration, User Profiles allows Reflected XSS.This issue a…
CVSS 3.1HIGH 7.1· Network · No auth · User interaction · EPSS 0.00412 · Published 2023-11-30 · No fix listed CWE-79
Priority LOW 31
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in PeepSo Community by PeepSo.This issue affects Community by PeepSo: from n/a through 6.0.9.0.
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.00505 · Published 2024-03-26 · No fix listed CWE-200
Priority LOW 30
Insertion of Sensitive Information into Log File vulnerability in PeepSo Community by PeepSo.This issue affects Community by PeepSo: from n/a through 6.2.7.0.
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.00443 · Published 2024-03-28 · No fix listed CWE-532
Priority LOW 30
The PeepSo Core: File Uploads plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 6.4.6.0 via the file_download REST API endpoint due to missing validation on a us…
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.00295 · Published 2025-05-14 · No fix listed CWE-639
Priority LOW 30
The Community by PeepSo – Social Network, Membership, Registration, User Profiles plugin for WordPress is vulnerable to Full Path Disclosure in all versions up to, and including, 6.4.6.0.
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.00452 · Published 2024-09-25 · No fix listed CWE-200
Priority LOW 29
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in PeepSo Community by PeepSo – Social Network, Membership, Registration, User Profiles allows Stored XSS.This issue affe…
CVSS 3.1MEDIUM 6.5· Network · Low privileges · User interaction · EPSS 0.00317 · Published 2024-01-31 · Fixed in 6.3.1.0 CWE-79
Priority LOW 29
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in PeepSo Community by PeepSo – Social Network, Membership, Registration, User Profiles allows Stored XSS.This issue affe…
CVSS 3.1MEDIUM 6.5· Network · Low privileges · User interaction · EPSS 0.00385 · Published 2023-11-30 · No fix listed CWE-79
Priority LOW 28
The Community by PeepSo – Download from PeepSo.com plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘filter’ parameter in all versions up to, and including, 7.0.3.0 due to insufficient input s…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00598 · Published 2024-11-21 · No fix listed CWE-79
Priority LOW 24
The Community by PeepSo – Social Network, Membership, Registration, User Profiles, Premium – Mobile App plugin for WordPress is vulnerable to Stored Cross-Site Scripting via URLs in posts, comments, and profiles when Mar…
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00279 · Published 2024-10-16 · No fix listed CWE-79
Priority LOW 22
The Community by PeepSo – Social Network, Membership, Registration, User Profiles plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 6.4.5.0 due to insufficient input…
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00336 · Published 2024-09-10 · No fix listed CWE-79
Priority LOW 22
The Community by PeepSo – Social Network, Membership, Registration, User Profiles plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘content’ parameter in all versions up to, and including, 6.4.5.…
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00336 · Published 2024-09-10 · No fix listed CWE-79
Priority LOW 20
The Community by PeepSo WordPress plugin before 6.3.1.2 does not have CSRF check when creating a user post (visible on their wall in their profile page), which could allow attackers to make logged in users perform such a…
CVSS 3.1MEDIUM 4.3· Network · No auth · User interaction · EPSS 0.00237 · Published 2024-01-16 · Fixed in 6.3.1.2 CWE-352
Priority LOW 19
Cross-Site Request Forgery (CSRF) vulnerability in PeepSo Community by PeepSo.This issue affects Community by PeepSo: from n/a through 6.3.1.1.
CVSS 3.1MEDIUM 4.3· Network · No auth · User interaction · EPSS 0.00176 · Published 2024-04-12 · No fix listed CWE-352