Adobe Commerce Incorrect Authorization Security feature bypass
Priority LOW 21CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
Adobe Commerce versions 2.4.4-p2 (and earlier) and 2.4.5-p1 (and earlier) are affected by an Incorrect Authorization vulnerability. A low-privileged authenticated attacker could leverage this vulnerability to achieve minor information disclosure.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00563 47th percentileScored 2026-11-07
Fix Fixed magento/community-edition (Packagist): 2.4.4-p3, 2.4.5-p2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Adobe | Magento Commerce | up to 2.4.5-p1; up to 2.4.4-p2; up to None | — | No fix listed | CNA |
| — | magento/community-edition (Packagist) | 2.4.4-p1 to before 2.4.4-p3 | 2.4.4-p3 | Patch available | GHSA-2wm7-mmgc-qxr3 |
| — | magento/community-edition (Packagist) | 2.4.5-p1 to before 2.4.5-p2 | 2.4.5-p2 | Patch available | GHSA-2wm7-mmgc-qxr3 |
| — | magento/community-edition (Packagist) | — | — | No fix listed | GHSA-2wm7-mmgc-qxr3 |
| — | magento/community-edition (Packagist) | — | — | No fix listed | GHSA-2wm7-mmgc-qxr3 |
| — | magento/project-community-edition (Packagist) | up to 2.0.2 | — | No fix listed | GHSA-2wm7-mmgc-qxr3 |
- Magento Commerce VendorAdobe Affected up to 2.4.5-p1; up to 2.4.4-p2; up to None Fixed in — No fix listed CNA
- magento/community-edition (Packagist) Vendor— Affected 2.4.4-p1 to before 2.4.4-p3 Fixed in 2.4.4-p3 Patch available GHSA-2wm7-mmgc-qxr3
- magento/community-edition (Packagist) Vendor— Affected 2.4.5-p1 to before 2.4.5-p2 Fixed in 2.4.5-p2 Patch available GHSA-2wm7-mmgc-qxr3
- magento/community-edition (Packagist) Vendor— Affected — Fixed in — No fix listed GHSA-2wm7-mmgc-qxr3
- magento/community-edition (Packagist) Vendor— Affected — Fixed in — No fix listed GHSA-2wm7-mmgc-qxr3
- magento/project-community-edition (Packagist) Vendor— Affected up to 2.0.2 Fixed in — No fix listed GHSA-2wm7-mmgc-qxr3
CPE configurations NVD · 12
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:adobe:commerce:*:*:*:*:*:*:*:* | before 2.4.4 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.4:-:*:*:*:*:*:* | 2.4.4 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.4:p1:*:*:*:*:*:* | 2.4.4 p1 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.4:p2:*:*:*:*:*:* | 2.4.4 p2 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.5:-:*:*:*:*:*:* | 2.4.5 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.5:p1:*:*:*:*:*:* | 2.4.5 p1 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:magento_open_source:*:*:*:*:*:*:*:* | before 2.4.4 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:magento_open_source:2.4.4:-:*:*:*:*:*:* | 2.4.4 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:magento_open_source:2.4.4:p1:*:*:*:*:*:* | 2.4.4 p1 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:magento_open_source:2.4.4:p2:*:*:*:*:*:* | 2.4.4 p2 | Vulnerable | Adobe |
- cpe:2.3:a:adobe:commerce:*:*:*:*:*:*:*:* Versions before 2.4.4 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.4:-:*:*:*:*:*:* Versions 2.4.4 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.4:p1:*:*:*:*:*:* Versions 2.4.4 p1 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.4:p2:*:*:*:*:*:* Versions 2.4.4 p2 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.5:-:*:*:*:*:*:* Versions 2.4.5 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.5:p1:*:*:*:*:*:* Versions 2.4.5 p1 Vulnerable ·Adobe
- cpe:2.3:a:adobe:magento_open_source:*:*:*:*:*:*:*:* Versions before 2.4.4 Vulnerable ·Adobe
- cpe:2.3:a:adobe:magento_open_source:2.4.4:-:*:*:*:*:*:* Versions 2.4.4 Vulnerable ·Adobe
- cpe:2.3:a:adobe:magento_open_source:2.4.4:p1:*:*:*:*:*:* Versions 2.4.4 p1 Vulnerable ·Adobe
- cpe:2.3:a:adobe:magento_open_source:2.4.4:p2:*:*:*:*:*:* Versions 2.4.4 p2 Vulnerable ·Adobe
Remediation
- Fix · GHSA-2wm7-mmgc-qxr3 magento/community-edition (Packagist) Fixed in 2.4.4-p3 Advisory →
- Fix · GHSA-2wm7-mmgc-qxr3 magento/community-edition (Packagist) Fixed in 2.4.5-p2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-22251
- 2026-10-03 Alias added: GHSA-2wm7-mmgc-qxr3
References
More Adobe Commerce vulnerabilities
- TI-2026-52938 Adobe Commerce | Improper Neutralization of Special Elements Used in a Template Engine (CWE-1336) KEVCVSS 3.1CRITICAL 10.0
- TI-2024-22559 XXE can expose crypt key and other secrets granting full admin access KEVCVSS 3.1CRITICAL 9.8
- TI-2022-08035 Adobe Commerce checkout improper input validation leads to remote code execution KEVCVSS 3.1CRITICAL 9.8
- TI-2026-35762 Unrestricted file upload in Adobe Commerce allows code execution KEVCVSS 3.1CRITICAL 9.3
- TI-2026-50010 Adobe Commerce | Incorrect Authorization (CWE-863) KEVCVSS 3.1CRITICAL 9.1
- TI-2025-34067 Adobe Commerce | Improper Input Validation (CWE-20) KEVCVSS 3.1CRITICAL 9.1
Sources
- CVE-2023-22251 · CVE Program
- CVE-2023-22251 · NVD
- FIRST EPSS
- GHSA-2wm7-mmgc-qxr3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences