Read the docs
TI-2023-08707 Aliases CVE-2023-22457GHSA-6mjp-2rm6-9g85

org.xwiki.contrib:application-ckeditor-ui vulnerable to Remote Code Execution via Cross-Site Request Forgery

Priority HIGH 74CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

CKEditor Integration UI adds support for editing wiki pages using CKEditor. Prior to versions 1.64.3,t he `CKEditor.HTMLConverter` document lacked a protection against Cross-Site Request Forgery (CSRF), allowing to execute macros with the rights of the current user. If a privileged user with programming rights was tricked into executing a GET request to this document with certain parameters (e.g., via an image with a corresponding URL embedded in a comment or via a redirect), this would allow arbitrary remote code execution and the attacker could gain rights, access private information or impact the availability of the wiki. The issue has been patched in the CKEditor Integration version 1.64.3. This has also been patched in the version of the CKEditor integration that is bundled starting with XWiki 14.6 RC1. There are no known workarounds for this other than upgrading the CKEditor integration to a fixed version.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.19284 97th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed application-ckeditor (xwiki-contrib): 1.64.3org.xwiki.contrib:application-ckeditor-ui (Maven): 1.64.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
XWikiapplication-ckeditorbefore 1.64.31.64.3Patch availableCNA
—org.xwiki.contrib:application-ckeditor-ui (Maven)before 1.64.31.64.3Patch availableGHSA-6mjp-2rm6-9g85
  • application-ckeditor VendorXWiki Affected before 1.64.3 Fixed in 1.64.3 Patch available CNA
  • org.xwiki.contrib:application-ckeditor-ui (Maven) Vendor— Affected before 1.64.3 Fixed in 1.64.3 Patch available GHSA-6mjp-2rm6-9g85

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:xwiki:ckeditor_integration:*:*:*:*:*:xwiki:*:*before 1.64.3VulnerableXWiki
  • cpe:2.3:a:xwiki:ckeditor_integration:*:*:*:*:*:xwiki:*:* Versions before 1.64.3 Vulnerable ·XWiki

Remediation

  • Fix · CNA application-ckeditor (xwiki-contrib) Fixed in 1.64.3
  • Fix · GHSA-6mjp-2rm6-9g85 org.xwiki.contrib:application-ckeditor-ui (Maven) Fixed in 1.64.3 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-22457
  2. 2026-10-03 Alias added: GHSA-6mjp-2rm6-9g85

References

  • TI-2023-18318 Persistent Cross-site Scripting (XSS) through CKEditor Configuration pages in XWiki Platform CVSS 3.1CRITICAL 9.1

Sources