Persistent Cross-site Scripting (XSS) through CKEditor Configuration pages in XWiki Platform
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Any user with edit rights can edit all pages in the `CKEditor' space. This makes it possible to perform a variety of harmful actions, such as removing technical documents, leading to loss of service and editing the javascript configuration of CKEditor, leading to persistent XSS. This issue has been patched in XWiki 14.10.6 and XWiki 15.1. This issue has been patched on the CKEditor Integration extension 1.64.9 for XWiki version older than 14.6RC1. Users are advised to upgrade. Users unable to upgrade may manually address the issue by restricting the `edit` and `delete` rights to a trusted user or group (e.g. the `XWiki.XWikiAdminGroup` group), implicitly disabling those rights for all other users. See commit `9d9d86179` for details.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| XWiki | xwiki-platform | org.xwiki.contrib:application-ckeditor-ui: >= 1.9, < 1.64.9; org.xwiki.platform:xwiki-platform-ckeditor-ui: >= 14.6-rc-1, < 14.10.6; org.xwiki.platform:xwiki-platform-ckeditor-ui: >= 15.0, < 15.1 | — | No fix listed | CNA |
| — | org.xwiki.platform:xwiki-platform-ckeditor-ui (Maven) | 14.6-rc-1 to before 14.10.6 | 14.10.6 | Patch available | GHSA-793w-g325-hrw2 |
| — | org.xwiki.contrib:application-ckeditor-ui (Maven) | 1.9 to before 1.64.9 | 1.64.9 | Patch available | GHSA-793w-g325-hrw2 |
| — | org.xwiki.platform:xwiki-platform-ckeditor-ui (Maven) | 15.0-rc-1 to before 15.1 | 15.1 | Patch available | GHSA-793w-g325-hrw2 |
- xwiki-platform VendorXWiki Affected org.xwiki.contrib:application-ckeditor-ui: >= 1.9, < 1.64.9; org.xwiki.platform:xwiki-platform-ckeditor-ui: >= 14.6-rc-1, < 14.10.6; org.xwiki.platform:xwiki-platform-ckeditor-ui: >= 15.0, < 15.1 Fixed in — No fix listed CNA
- org.xwiki.platform:xwiki-platform-ckeditor-ui (Maven) Vendor— Affected 14.6-rc-1 to before 14.10.6 Fixed in 14.10.6 Patch available GHSA-793w-g325-hrw2
- org.xwiki.contrib:application-ckeditor-ui (Maven) Vendor— Affected 1.9 to before 1.64.9 Fixed in 1.64.9 Patch available GHSA-793w-g325-hrw2
- org.xwiki.platform:xwiki-platform-ckeditor-ui (Maven) Vendor— Affected 15.0-rc-1 to before 15.1 Fixed in 15.1 Patch available GHSA-793w-g325-hrw2
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:xwiki:ckeditor_integration:*:*:*:*:*:xwiki:*:* | 1.9 to before 1.64.9 | Vulnerable | XWiki |
| cpe:2.3:a:xwiki:xwiki:*:*:*:*:*:*:*:* | 14.6 to before 14.10.6 | Vulnerable | XWiki |
| cpe:2.3:a:xwiki:xwiki:15.0:-:*:*:*:*:*:* | 15.0 | Vulnerable | XWiki |
| cpe:2.3:a:xwiki:xwiki:15.0:rc1:*:*:*:*:*:* | 15.0 rc1 | Vulnerable | XWiki |
- cpe:2.3:a:xwiki:ckeditor_integration:*:*:*:*:*:xwiki:*:* Versions 1.9 to before 1.64.9 Vulnerable ·XWiki
- cpe:2.3:a:xwiki:xwiki:*:*:*:*:*:*:*:* Versions 14.6 to before 14.10.6 Vulnerable ·XWiki
- cpe:2.3:a:xwiki:xwiki:15.0:-:*:*:*:*:*:* Versions 15.0 Vulnerable ·XWiki
- cpe:2.3:a:xwiki:xwiki:15.0:rc1:*:*:*:*:*:* Versions 15.0 rc1 Vulnerable ·XWiki
Remediation
- Fix · GHSA-793w-g325-hrw2 org.xwiki.platform:xwiki-platform-ckeditor-ui (Maven) Fixed in 14.10.6 Advisory →
- Fix · GHSA-793w-g325-hrw2 org.xwiki.contrib:application-ckeditor-ui (Maven) Fixed in 1.64.9 Advisory →
- Fix · GHSA-793w-g325-hrw2 org.xwiki.platform:xwiki-platform-ckeditor-ui (Maven) Fixed in 15.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-36477
- 2026-10-03 Alias added: GHSA-793w-g325-hrw2
References
Exploit 3
More XWiki Ckeditor Integration vulnerabilities
- TI-2023-08707 org.xwiki.contrib:application-ckeditor-ui vulnerable to Remote Code Execution via Cross-Site Request Forgery CVSS 3.1CRITICAL 9.1
Sources
- CVE-2023-36477 · CVE Program
- CVE-2023-36477 · NVD
- FIRST EPSS
- GHSA-793w-g325-hrw2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences