Missing authorization in Flarum
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
Flarum is a forum software for building communities. Using the notifications feature, one can read restricted/private content and bypass access checks that would be in place for such content. The notification-sending component does not check that the subject of the notification can be seen by the receiver, and proceeds to send notifications through their different channels. The alerts do not leak data despite this as they are listed based on a visibility check, however, emails are still sent out. This means that, for extensions which restrict access to posts, any actor can bypass the restriction by subscribing to the discussion if the Subscriptions extension is enabled. The attack allows the leaking of some posts in the forum database, including posts awaiting approval, posts in tags the user has no access to if they could subscribe to a discussion before it becomes private, and posts restricted by third-party extensions. All Flarum versions prior to v1.6.3 are affected. The vulnerability has been fixed and published as flarum/core v1.6.3. All communities running Flarum should upgrade as soon as possible to v1.6.3. As a workaround, disable the Flarum Subscriptions extension or disable email notifications altogether. There are no other supported workarounds for this issue for Flarum versions below 1.6.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| flarum | framework | before 1.6.3 | 1.6.3 | Patch available | CNA |
| — | flarum/core (Packagist) | before 1.6.3 | 1.6.3 | Patch available | GHSA-8gcg-vwmw-rxj4 |
- framework Vendorflarum Affected before 1.6.3 Fixed in 1.6.3 Patch available CNA
- flarum/core (Packagist) Vendor— Affected before 1.6.3 Fixed in 1.6.3 Patch available GHSA-8gcg-vwmw-rxj4
Remediation
- Fix · CNA framework (flarum) Fixed in 1.6.3
- Fix · GHSA-8gcg-vwmw-rxj4 flarum/core (Packagist) Fixed in 1.6.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-22488
- 2026-10-03 Alias added: GHSA-8gcg-vwmw-rxj4
References
Advisory 2
More Flarum vulnerabilities
- TI-2021-12339 XSS vulnerability with translator CVSS 3.1CRITICAL 10.0
- TI-2023-08736 Post mentions can be used to read any post on the forum without access control CVSS 3.1HIGH 7.7
- TI-2025-20573 Flarum Vulnerable to Session Hijacking via Authoritative Subdomain Cookie Overwrite CVSS 3.1MEDIUM 6.8
- TI-2022-20279 Cross site scripting vulnerability with discussion titles in flarum CVSS 3.1CRITICAL 9.0
- TI-2019-09878 Flarum before 0.1.0-beta.9 allows CSRF against all POST endpoints, as demonstrated by changing admin settings. CVSS 3.0HIGH 8.8
- TI-2019-08604 User/Command/ConfirmEmailHandler.php in Flarum before 0.1.0-beta.8 mishandles invalidation of user email tokens. CVSS 3.0HIGH 7.5
Sources
- CVE-2023-22488 · CVE Program
- CVE-2023-22488 · NVD
- FIRST EPSS
- GHSA-8gcg-vwmw-rxj4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences