Flarum is missing authorization in discussion replies
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
Flarum is a discussion platform for websites. If the first post of a discussion is permanently deleted but the discussion stays visible, any actor who can view the discussion is able to create a new reply via the REST API, no matter the reply permission or lock status. This includes users that don't have a validated email. Guests cannot successfully create a reply because the API will fail with a 500 error when the user ID 0 is inserted into the database. This happens because when the first post of a discussion is permanently deleted, the `first_post_id` attribute of the discussion becomes `null` which causes access control to be skipped for all new replies. Flarum automatically makes discussions with zero comments invisible so an additional condition for this vulnerability is that the discussion must have at least one approved reply so that `discussions.comment_count` is still above zero after the post deletion. This can open the discussion to uncontrolled spam or just unintentional replies if users still had their tab open before the vulnerable discussion was locked and then post a reply when they shouldn't be able to. In combination with the email notification settings, this could also be used as a way to send unsolicited emails. Versions between `v1.3.0` and `v1.6.3` are impacted. The vulnerability has been fixed and published as flarum/core v1.6.3. All communities running Flarum should upgrade as soon as possible. There are no known workarounds.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| flarum | framework | 1.3.0 to before 1.6.3 | 1.6.3 | Patch available | CNA |
| — | flarum/core (Packagist) | 1.3.0 to before 1.6.3 | 1.6.3 | Patch available | GHSA-hph3-hv3c-7725 |
- framework Vendorflarum Affected 1.3.0 to before 1.6.3 Fixed in 1.6.3 Patch available CNA
- flarum/core (Packagist) Vendor— Affected 1.3.0 to before 1.6.3 Fixed in 1.6.3 Patch available GHSA-hph3-hv3c-7725
Remediation
- Fix · CNA framework (flarum) Fixed in 1.6.3
- Fix · GHSA-hph3-hv3c-7725 flarum/core (Packagist) Fixed in 1.6.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-22489
- 2026-10-03 Alias added: GHSA-hph3-hv3c-7725
References
Advisory 3
More Flarum vulnerabilities
- TI-2021-12339 XSS vulnerability with translator CVSS 3.1CRITICAL 10.0
- TI-2023-08736 Post mentions can be used to read any post on the forum without access control CVSS 3.1HIGH 7.7
- TI-2025-20573 Flarum Vulnerable to Session Hijacking via Authoritative Subdomain Cookie Overwrite CVSS 3.1MEDIUM 6.8
- TI-2022-20279 Cross site scripting vulnerability with discussion titles in flarum CVSS 3.1CRITICAL 9.0
- TI-2019-09878 Flarum before 0.1.0-beta.9 allows CSRF against all POST endpoints, as demonstrated by changing admin settings. CVSS 3.0HIGH 8.8
- TI-2019-08604 User/Command/ConfirmEmailHandler.php in Flarum before 0.1.0-beta.8 mishandles invalidation of user email tokens. CVSS 3.0HIGH 7.5
Sources
- CVE-2023-22489 · CVE Program
- CVE-2023-22489 · NVD
- FIRST EPSS
- GHSA-hph3-hv3c-7725 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences