OpenMage LTS has DoS vulnerability in MaliciousCode filter
Priority LOW 35CWE-835Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-835.
Summary
OpenMage LTS is an e-commerce platform. Versions prior to 19.4.22 and 20.0.19 contain an infinite loop in malicious code filter in certain conditions. Versions 19.4.22 and 20.0.19 have a fix for this issue. There are no known workarounds.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01031 63rd percentileScored 2026-11-07
Fix Fixed magento-lts (OpenMage): 19.4.22, 20.0.19openmage/magento-lts (Packagist): 19.4.22, 20.0.19
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| OpenMage | magento-lts | before 19.4.22; 20.0.0 to before 20.0.19 | 19.4.22, 20.0.19 | Patch available | CNA |
| — | openmage/magento-lts (Packagist) | before 19.4.22 | 19.4.22 | Patch available | GHSA-3p73-mm7v-4f6m |
| — | openmage/magento-lts (Packagist) | 20.0.0 to before 20.0.19 | 20.0.19 | Patch available | GHSA-3p73-mm7v-4f6m |
- magento-lts VendorOpenMage Affected before 19.4.22; 20.0.0 to before 20.0.19 Fixed in 19.4.22, 20.0.19 Patch available CNA
- openmage/magento-lts (Packagist) Vendor— Affected before 19.4.22 Fixed in 19.4.22 Patch available GHSA-3p73-mm7v-4f6m
- openmage/magento-lts (Packagist) Vendor— Affected 20.0.0 to before 20.0.19 Fixed in 20.0.19 Patch available GHSA-3p73-mm7v-4f6m
Remediation
- Fix · CNA magento-lts (OpenMage) Fixed in 19.4.22, 20.0.19
- Fix · GHSA-3p73-mm7v-4f6m openmage/magento-lts (Packagist) Fixed in 19.4.22 Advisory →
- Fix · GHSA-3p73-mm7v-4f6m openmage/magento-lts (Packagist) Fixed in 20.0.19 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-23617
- 2026-10-03 Alias added: GHSA-3p73-mm7v-4f6m
References
Advisory 4
More OpenMage Magento vulnerabilities
- TI-2026-20633 OpenMage LTS's Phar Deserialization leads to Remote Code Execution CVSS 3.1HIGH 8.1
- TI-2026-29239 OpenMage LTS has Customer File Upload Extension Blocklist Bypass that Leads to Remote Code Execution CVSS 4.0HIGH 8.7
- TI-2023-22272 Magento LTS's guest order "protect code" can be brute-forced too easily CVSS 3.1HIGH 7.5
- TI-2026-28925 Missing authorization in OpenMage magento-lts CVSS 4.0MEDIUM 5.3
- TI-2026-20634 OpenMage LTS has Path Traversal Filter Bypass in Dataflow Module CVSS 3.1MEDIUM 4.9
- TI-2025-39617 OpenMage is vulnerable to XSS in Admin Notifications CVSS 4.0MEDIUM 4.6
Sources
- CVE-2023-23617 · CVE Program
- CVE-2023-23617 · NVD
- FIRST EPSS
- GHSA-3p73-mm7v-4f6m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences