Missing authorization in Synopsys Jenkins Coverity Plugin
Priority LOW 21CWE-862Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
A missing permission check in Synopsys Jenkins Coverity Plugin 3.0.2 and earlier allows attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00509 43rd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:synopsys-coverity (Maven): 3.0.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Synopsys | Synopsys Jenkins Coverity Plugin | up to 3.0.2 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:synopsys-coverity (Maven) | before 3.0.3 | 3.0.3 | Patch available | GHSA-jwr6-75xh-jh5j |
- Synopsys Jenkins Coverity Plugin VendorSynopsys Affected up to 3.0.2 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:synopsys-coverity (Maven) Vendor— Affected before 3.0.3 Fixed in 3.0.3 Patch available GHSA-jwr6-75xh-jh5j
Remediation
- Fix · GHSA-jwr6-75xh-jh5j org.jenkins-ci.plugins:synopsys-coverity (Maven) Fixed in 3.0.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-23850
- 2026-10-03 Alias added: GHSA-jwr6-75xh-jh5j
References
Advisory 2
More Synopsys vulnerabilities
- TI-2023-02026 Impersonation through User-Controlled Token CVSS 3.1CRITICAL 9.8
- TI-2023-09648 Cross-site scripting in Synopsys Coverity CVSS 3.1HIGH 8.1
- TI-2019-02812 CF CLI writes the client id and secret to config file CVSS 3.0HIGH 7.8
- TI-2023-01560 Authenticated Resources Accessible via Forced Browsing CVSS 3.1MEDIUM 6.5
- TI-2020-16716 Synopsys hub-rest-api-python (aka blackduck on PyPI) version 0.0.25 - 0.0.52 does not… CVSS 3.1HIGH 7.5
- TI-2022-12517 Cross-site scripting in Synopsys Black Duck Hub CVSS 3.1MEDIUM 6.1
Sources
- CVE-2023-23850 · CVE Program
- CVE-2023-23850 · NVD
- FIRST EPSS
- GHSA-jwr6-75xh-jh5j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences