Read the docs

Synopsys

Records10All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical1CVSS 9.0–10.0
CVSS high3CVSS 7.0–8.9

Exploited now

Synopsys records in CISA KEV

No Synopsys vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

10 records

Priority MEDIUM 50

Code Dx versions prior to 2023.4.2 are vulnerable to user impersonation attack where a malicious actor is able to gain access to another user's account by crafting a custom "Remember Me" token.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00621 Published 2023-04-27 No fix listed CWE-321
TI-2023-09648 CVE-2023-23849 · GHSA-7gvj-8qmv-p4vc

Cross-site scripting in Synopsys Coverity

Priority MEDIUM 40

Versions of Coverity Connect prior to 2022.12.0 are vulnerable to an unauthenticated Cross-Site Scripting vulnerability.

CVSS 3.1HIGH 8.1 Network No auth No interaction EPSS 0.01298 Published 2023-02-06 Fixed in 2022.12.0 CWE-79
Priority LOW 38

CF CLI version prior to v6.45.0 (bosh release version 1.16.0) writes the client id and secret to its config file when the user authenticates with --client-credentials flag.

CVSS 3.0HIGH 7.8 Local Low privileges No interaction EPSS 0.02088 Published 2019-08-05 Fixed in v1.16.0, v6.45.0 CWE-522
Priority LOW 35

Coverity versions prior to 2023.3.2 are vulnerable to forced browsing, which exposes authenticated resources to unauthorized actors.

CVSS 3.1MEDIUM 6.5 Network No auth No interaction EPSS 0.00431 Published 2023-03-29 No fix listed CWE-425
Priority LOW 29

A vulnerability in Black Duck Hub’s embedded MadCap Flare documentation files could allow an unauthenticated remote attacker to conduct a cross-site scripting attack.

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00828 Published 2022-05-10 Fixed in 2022.4.0 CWE-79
Priority LOW 24

Synopsys Seeker versions prior to 2023.12.0 are vulnerable to a stored cross-site scripting vulnerability through a specially crafted payload.

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00286 Published 2024-01-09 Fixed in 2023.12.0 CWE-79
Priority LOW 21

A missing permission check in Synopsys Jenkins Coverity Plugin 3.0.2 and earlier allows attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins.

CVSS 3.1MEDIUM 4.3 Network Low privileges No interaction EPSS 0.00509 Published 2023-02-15 Fixed in 3.0.3 CWE-862
Priority LOW 21

Missing permission checks in Synopsys Jenkins Coverity Plugin 3.0.2 and earlier allow attackers with Overall/Read permission to connect to an attacker-specified HTTP server using attacker-specified credentials IDs obtain…

CVSS 3.1MEDIUM 4.3 Network Low privileges No interaction EPSS 0.0052 Published 2023-02-15 Fixed in 3.0.3 CWE-862
Priority LOW 17

A cross-site request forgery (CSRF) vulnerability in Synopsys Jenkins Coverity Plugin 3.0.2 and earlier allows attackers to connect to an attacker-specified HTTP server using attacker-specified credentials IDs obtained t…

CVSS 3.1LOW 3.5 Network Low privileges User interaction EPSS 0.00357 Published 2023-02-15 Fixed in 3.0.3 CWE-352
Open these records in search →