Apollo has potential access control security issue in eureka
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-306.
Summary
Apollo is a configuration management system. Prior to version 2.1.0, there are potential security issues if users expose apollo-configservice to the internet, which is not recommended. This is because there is no authentication feature enabled for the built-in eureka service. Malicious hackers may access eureka directly to mock apollo-configservice and apollo-adminservice. Login authentication for eureka was added in version 2.1.0. As a workaround, avoid exposing apollo-configservice to the internet.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| apolloconfig | apollo | before 2.1.0 | 2.1.0 | Patch available | CNA |
| — | com.ctrip.framework.apollo:apollo (Maven) | before 2.1.0 | 2.1.0 | Patch available | GHSA-368x-wmmg-hq5c |
- apollo Vendorapolloconfig Affected before 2.1.0 Fixed in 2.1.0 Patch available CNA
- com.ctrip.framework.apollo:apollo (Maven) Vendor— Affected before 2.1.0 Fixed in 2.1.0 Patch available GHSA-368x-wmmg-hq5c
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apolloconfig:apollo:*:*:*:*:*:*:*:* | before 2.1.0 | Vulnerable | apolloconfig |
- cpe:2.3:a:apolloconfig:apollo:*:*:*:*:*:*:*:* Versions before 2.1.0 Vulnerable ·apolloconfig
Remediation
- Fix · CNA apollo (apolloconfig) Fixed in 2.1.0
- Fix · GHSA-368x-wmmg-hq5c com.ctrip.framework.apollo:apollo (Maven) Fixed in 2.1.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-25570
- 2026-10-03 Alias added: GHSA-368x-wmmg-hq5c
References
Patch 2
Advisory 2
More apolloconfig Apollo vulnerabilities
- TI-2022-04551 Apollo Configuration Center users improper authorization CVSS 3.1MEDIUM 4.3
- TI-2024-28573 An issue in apollocongif apollo v.2.2.0 allows a remote attacker to obtain sensitive information via a crafted request. CVSS 3.1HIGH 7.5
- TI-2023-10872 apollo-portal has potential CSRF issue CVSS 3.1MEDIUM 5.7
- TI-2024-29046 Potential unauthorized access issue in apollo-portal CVSS 3.1MEDIUM 4.3
Sources
- CVE-2023-25570 · CVE Program
- CVE-2023-25570 · NVD
- FIRST EPSS
- GHSA-368x-wmmg-hq5c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences