Potential unauthorized access issue in apollo-portal
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
Apollo is a configuration management system. A vulnerability exists in the synchronization configuration feature that allows users to craft specific requests to bypass permission checks. This exploit enables them to modify a namespace without the necessary permissions. The issue was addressed with an input parameter check which was released in version 2.3.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| apolloconfig | apollo | before 2.3.0 | 2.3.0 | Patch available | CNA |
| — | com.ctrip.framework.apollo:apollo (Maven) | before 2.3.0 | 2.3.0 | Patch available | GHSA-c6c3-h4f7-3962 |
- apollo Vendorapolloconfig Affected before 2.3.0 Fixed in 2.3.0 Patch available CNA
- com.ctrip.framework.apollo:apollo (Maven) Vendor— Affected before 2.3.0 Fixed in 2.3.0 Patch available GHSA-c6c3-h4f7-3962
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apolloconfig:apollo:*:*:*:*:*:*:*:* | before 2.3.0 | Vulnerable | apolloconfig |
- cpe:2.3:a:apolloconfig:apollo:*:*:*:*:*:*:*:* Versions before 2.3.0 Vulnerable ·apolloconfig
Remediation
- Fix · CNA apollo (apolloconfig) Fixed in 2.3.0
- Fix · GHSA-c6c3-h4f7-3962 com.ctrip.framework.apollo:apollo (Maven) Fixed in 2.3.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-43397
- 2026-10-03 Alias added: GHSA-c6c3-h4f7-3962
References
Patch 2
Advisory 2
More apolloconfig Apollo vulnerabilities
- TI-2022-04551 Apollo Configuration Center users improper authorization CVSS 3.1MEDIUM 4.3
- TI-2023-10873 Apollo has potential access control security issue in eureka CVSS 3.1HIGH 7.5
- TI-2024-28573 An issue in apollocongif apollo v.2.2.0 allows a remote attacker to obtain sensitive information via a crafted request. CVSS 3.1HIGH 7.5
- TI-2023-10872 apollo-portal has potential CSRF issue CVSS 3.1MEDIUM 5.7
Sources
- CVE-2024-43397 · CVE Program
- CVE-2024-43397 · NVD
- FIRST EPSS
- GHSA-c6c3-h4f7-3962 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences