Cross-site scripting in quill-mention
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Versions of the package quill-mention before 4.0.0 are vulnerable to Cross-site Scripting (XSS) due to improper user-input sanitization, via the renderList function. **Note:** If the mentions list is sourced from unsafe (user-sourced) data, this might allow an injection attack when a Quill user hits @.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00708 53rd percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed quill-mention: 4.0.0quill-mention (npm): 4.0.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | quill-mention | before 4.0.0 | 4.0.0 | Patch available | CNA |
| — | quill-mention (npm) | before 4.0.0 | 4.0.0 | Patch available | GHSA-jgw5-rp4p-qhp6 |
- quill-mention Vendor— Affected before 4.0.0 Fixed in 4.0.0 Patch available CNA
- quill-mention (npm) Vendor— Affected before 4.0.0 Fixed in 4.0.0 Patch available GHSA-jgw5-rp4p-qhp6
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:quill-mention:quill_mention:*:*:*:*:*:node.js:*:* | before 4.0.0 | Vulnerable | Quill-mention |
- cpe:2.3:a:quill-mention:quill_mention:*:*:*:*:*:node.js:*:* Versions before 4.0.0 Vulnerable ·Quill-mention
Remediation
- Fix · CNA quill-mention Fixed in 4.0.0
- Fix · GHSA-jgw5-rp4p-qhp6 quill-mention (npm) Fixed in 4.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-26149
- 2026-10-03 Alias added: GHSA-jgw5-rp4p-qhp6
References
Exploit 2
Patch 2
Sources
- CVE-2023-26149 · CVE Program
- CVE-2023-26149 · NVD
- FIRST EPSS
- GHSA-jgw5-rp4p-qhp6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences