SPIP before 4.2.1 allows Remote Code Execution via form values in the public area because…
Priority CRITICAL 94CWE-502Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-502.
Summary
SPIP before 4.2.1 allows Remote Code Execution via form values in the public area because serialization is mishandled. The fixed versions are 3.2.18, 4.0.10, 4.1.8, and 4.2.1.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.99682 99th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:spip:spip:*:*:*:*:*:*:*:* | before 3.2.18; 4.0.0 to before 4.0.10; 4.1.0 to before 4.1.8 | Vulnerable | SPIP |
| cpe:2.3:a:spip:spip:4.2.0:-:*:*:*:*:*:* | 4.2.0 | Vulnerable | SPIP |
| cpe:2.3:a:spip:spip:4.2.0:alpha:*:*:*:*:*:* | 4.2.0 alpha | Vulnerable | SPIP |
| cpe:2.3:a:spip:spip:4.2.0:alpha2:*:*:*:*:*:* | 4.2.0 alpha2 | Vulnerable | SPIP |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
- cpe:2.3:a:spip:spip:*:*:*:*:*:*:*:* Versions before 3.2.18; 4.0.0 to before 4.0.10; 4.1.0 to before 4.1.8 Vulnerable ·SPIP
- cpe:2.3:a:spip:spip:4.2.0:-:*:*:*:*:*:* Versions 4.2.0 Vulnerable ·SPIP
- cpe:2.3:a:spip:spip:4.2.0:alpha:*:*:*:*:*:* Versions 4.2.0 alpha Vulnerable ·SPIP
- cpe:2.3:a:spip:spip:4.2.0:alpha2:*:*:*:*:*:* Versions 4.2.0 alpha2 Vulnerable ·SPIP
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2023-27372
- 2026-10-03 Alias added: GHSA-jc3f-vxgp-6jw9
References
Patch 2
Advisory 1
Sources
- CVE-2023-27372 · CVE Program
- CVE-2023-27372 · NVD
- FIRST EPSS
- GHSA-jc3f-vxgp-6jw9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences