Read the docs

SPIP

Records88All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical20CVSS 9.0–10.0
CVSS high29CVSS 7.0–8.9

Exploited now

SPIP records in CISA KEV

No SPIP vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

88 records

Priority CRITICAL 92

The porte_plume plugin used by SPIP before 4.30-alpha2, 4.2.13, and 4.1.16 is vulnerable to an arbitrary code execution vulnerability.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.90053 Published 2024-08-23 Fixed in 4.3.0-alpha2, 4.2.13 +1 CWE-1286
Priority HIGH 81

SPIP before 4.4.18 contains a mass assignment vulnerability in the editer_objet action that allows unauthenticated attackers to write arbitrary rows to any SQL table lacking a champs_editables allowlist by supplying an a…

CVSS 4.0CRITICAL 9.3 Network No auth No interaction EPSS 0.01122 Published 2026-09-11 Fixed in 4.4.18 CWE-915
Priority HIGH 81

SPIP before version 4.4.18 contains a missing authorization vulnerability in sensitive actions under ecrire/action/ that allows unauthenticated attackers to invoke privileged actions by supplying only a valid CSRF nonce…

CVSS 4.0CRITICAL 9.3 Network No auth No interaction EPSS 0.00658 Published 2026-09-11 Fixed in 4.4.18 CWE-862
TI-2026-22104 CVE-2026-27744 · GHSA-68cf-j259-wgr8

SPIP tickets < 4.3.3 Unauthenticated RCE

Priority HIGH 81

The SPIP tickets plugin versions prior to 4.3.3 contain an unauthenticated remote code execution vulnerability in the forum preview handling for public ticket pages.

CVSS 4.0CRITICAL 9.3 Network No auth No interaction EPSS 0.01032 Published 2026-02-25 Fixed in 4.3.3 CWE-94
Priority HIGH 81

The SPIP referer_spam plugin versions prior to 1.3.0 contain an unauthenticated SQL injection vulnerability in the referer_spam_ajouter and referer_spam_supprimer action handlers.

CVSS 4.0CRITICAL 9.3 Network No auth No interaction EPSS 0.00677 Published 2026-02-25 Fixed in 1.3.0 CWE-89
Priority HIGH 77

SPIP before 4.4.18 contains an unauthenticated blind SQL injection vulnerability in the SQL escaping layer that allows unauthenticated attackers to inject arbitrary SQL by supplying a crafted annee parameter value matchi…

CVSS 4.0HIGH 8.7 Network No auth No interaction EPSS 0.00518 Published 2026-09-11 Fixed in 4.4.18 CWE-89
Priority HIGH 66

The SPIP interface_traduction_objets plugin versions prior to 2.2.2 contain an authenticated SQL injection vulnerability in interface_traduction_objets_pipelines.php.

CVSS 4.0HIGH 7.1 Network Low privileges No interaction EPSS 0.0043 Published 2026-02-25 Fixed in 2.2.2 CWE-89
Priority MEDIUM 57

The 'Saisies pour formulaire' (Saisies) plugin for SPIP versions 5.4.0 through 5.11.0 contains a critical Remote Code Execution (RCE) vulnerability.

CVSS 4.0CRITICAL 9.3 Network No auth No interaction EPSS 0.05595 Published 2026-02-19 Fixed in 5.11.1 CWE-94
Priority MEDIUM 57

Spip 4.1.10 contains a file upload vulnerability that allows attackers to upload malicious SVG files with embedded external links.

CVSS 4.0MEDIUM 4.8 Network Low privileges User interaction EPSS 0.00317 Published 2025-12-16 No fix listed CWE-79
TI-2026-54188 CVE-2026-77806 · GHSA-vgr8-rqwx-wqrp

Code injection in SPIP

Priority MEDIUM 56

SPIP before 4.4.21 allows unauthenticated remote attackers to execute arbitrary code, as exploited in the wild in August 2026.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.04479 Published 2026-08-21 Fixed in 4.4.21 CWE-94
Priority MEDIUM 56

The SPIP jeux plugin versions prior to 4.1.1 contain a reflected cross-site scripting (XSS) vulnerability in the pre_propre pipeline.

CVSS 4.0MEDIUM 5.1 Network No auth User interaction EPSS 0.0024 Published 2026-02-25 Fixed in 4.1.1 CWE-79
TI-2026-54117 CVE-2026-77647 · GHSA-wj6g-rh9q-6vvm

Code injection in SPIP

Priority MEDIUM 53

SPIP before 4.4.20 allows unauthenticated remote attackers to execute arbitrary code, as exploited in the wild in August 2026.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.02292 Published 2026-08-20 Fixed in 4.4.20 CWE-94
Priority MEDIUM 53

The SPIP template composer/compiler in SPIP 3.1.2 and earlier allows remote authenticated users to execute arbitrary PHP code by uploading an HTML file with a crafted (1) INCLUDE or (2) INCLURE tag and then accessing it…

CVSS 3.0HIGH 8.8 Network Low privileges No interaction EPSS 0.13293 Published 2017-01-18 No fix listed CWE-20
Priority MEDIUM 49

The Crayons plugin for SPIP before 3.5.0 contains a missing authorization vulnerability that allows unauthenticated attackers to modify arbitrary editable object fields by omitting the secu_ anti-forgery parameter in cra…

CVSS 4.0CRITICAL 9.3 Network No auth No interaction EPSS 0.00571 Published 2026-10-06 Fixed in 3.5.0 CWE-862
Priority MEDIUM 46

The encoder_contexte_ajax function in ecrire/inc/filtres.php in SPIP 2.x before 2.1.19, 3.0.x before 3.0.22, and 3.1.x before 3.1.1 allows remote attackers to conduct PHP object injection attacks and execute arbitrary PH…

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.01835 Published 2016-04-08 No fix listed CWE-94
Load more
Open these records in search →