Improper authentication in home-assistant core
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-287.
Summary
homeassistant is an open source home automation tool. A remotely exploitable vulnerability bypassing authentication for accessing the Supervisor API through Home Assistant has been discovered. This impacts all Home Assistant installation types that use the Supervisor 2023.01.1 or older. Installation types, like Home Assistant Container (for example Docker), or Home Assistant Core manually in a Python environment, are not affected. The issue has been mitigated and closed in Supervisor version 2023.03.1, which has been rolled out to all affected installations via the auto-update feature of the Supervisor. This rollout has been completed at the time of publication of this advisory. Home Assistant Core 2023.3.0 included mitigation for this vulnerability. Upgrading to at least that version is thus advised. In case one is not able to upgrade the Home Assistant Supervisor or the Home Assistant Core application at this time, it is advised to not expose your Home Assistant instance to the internet.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| home-assistant | core | before 2023.3.2 | 2023.3.2 | Patch available | CNA |
| home-assistant | supervisor | before 2023.03.3 | 2023.03.3 | Patch available | CNA |
- core Vendorhome-assistant Affected before 2023.3.2 Fixed in 2023.3.2 Patch available CNA
- supervisor Vendorhome-assistant Affected before 2023.03.3 Fixed in 2023.03.3 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:home-assistant:home-assistant:*:*:*:*:*:*:*:* | before 2023.3.0 | Vulnerable | home-assistant |
| cpe:2.3:a:home-assistant:supervisor:*:*:*:*:*:*:*:* | before 2023.03.1 | Vulnerable | home-assistant |
- cpe:2.3:a:home-assistant:home-assistant:*:*:*:*:*:*:*:* Versions before 2023.3.0 Vulnerable ·home-assistant
- cpe:2.3:a:home-assistant:supervisor:*:*:*:*:*:*:*:* Versions before 2023.03.1 Vulnerable ·home-assistant
Remediation
- Fix · CNA core (home-assistant) Fixed in 2023.3.2
- Fix · CNA supervisor (home-assistant) Fixed in 2023.03.3
Timeline
- 2026-10-02 Threatist record created from CVE-2023-27482
References
Advisory 2
More Home-assistant vulnerabilities
- TI-2026-25491 Home Assistant has stored XSS in history-graphs CVSS 4.0HIGH 7.3
- TI-2026-25490 Home Assistant has stored XSS in Map-card through malicious device name CVSS 4.0HIGH 7.3
- TI-2026-39212 Home Assistant: Konnected alarm-panel switch state and zone topology disclosed to unauthenticated actors on the LAN CVSS 3.1HIGH 7.6
- TI-2025-40423 Home Assistant Core before v2025.8.0 is vulnerable to Directory Traversal. CVSS 3.1MEDIUM 4.0
- TI-2023-22289 Lack of XFO header allows clickjacking in Home Assistant Core CVSS 3.1CRITICAL 9.6
- TI-2023-22287 Cross-site Scripting via auth_callback login in Home Assistant Core CVSS 3.1CRITICAL 9.6
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences