Home Assistant Core before v2025.8.0 is vulnerable to Directory Traversal.
Priority MEDIUM 52CWE-22Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.
Summary
Home Assistant Core before v2025.8.0 is vulnerable to Directory Traversal. The Downloader integration does not fully validate file paths during concatenation, leaving a path traversal vulnerability.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00405 34th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed homeassistant (PyPI): 2025.8.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | homeassistant (PyPI) | before 2025.8.0 | 2025.8.0 | Patch available | GHSA-pp3g-xmm4-5cw9 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- homeassistant (PyPI) Vendor— Affected before 2025.8.0 Fixed in 2025.8.0 Patch available GHSA-pp3g-xmm4-5cw9
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:home-assistant:home-assistant:*:*:*:*:*:*:*:* | before 2025.8.0 | Vulnerable | home-assistant |
- cpe:2.3:a:home-assistant:home-assistant:*:*:*:*:*:*:*:* Versions before 2025.8.0 Vulnerable ·home-assistant
Remediation
- Fix · GHSA-pp3g-xmm4-5cw9 homeassistant (PyPI) Fixed in 2025.8.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-65713
- 2026-10-03 Alias added: GHSA-pp3g-xmm4-5cw9
References
Other 4
- https://github.com/home-assistant/core
- https://github.com/home-assistant/core/blob/a4d12694dae82f10e2ca9c524e44a22ab7dacf66/homeassistant/components/downloader/services.py#L32
- https://github.com/home-assistant/core/blob/a4d12694dae82f10e2ca9c524e44a22ab7dacf66/homeassistant/util/__init__.py#L20
- https://github.com/home-assistant/core/blob/a4d12694dae82f10e2ca9c524e44a22ab7dacf66/homeassistant/util/__init__.py#L32-L38
More Home-assistant vulnerabilities
- TI-2023-12210 Improper authentication in home-assistant core CVSS 3.1CRITICAL 10.0
- TI-2026-25491 Home Assistant has stored XSS in history-graphs CVSS 4.0HIGH 7.3
- TI-2026-25490 Home Assistant has stored XSS in Map-card through malicious device name CVSS 4.0HIGH 7.3
- TI-2026-39212 Home Assistant: Konnected alarm-panel switch state and zone topology disclosed to unauthenticated actors on the LAN CVSS 3.1HIGH 7.6
- TI-2023-22289 Lack of XFO header allows clickjacking in Home Assistant Core CVSS 3.1CRITICAL 9.6
- TI-2023-22287 Cross-site Scripting via auth_callback login in Home Assistant Core CVSS 3.1CRITICAL 9.6
Sources
- CVE-2025-65713 · CVE Program
- CVE-2025-65713 · NVD
- FIRST EPSS
- GHSA-pp3g-xmm4-5cw9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences