Path Traversal Vulnerability in `LESS` Parser allows reading of sensitive server files in flarum
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
flarum is a forum software package for building communities. In versions prior to 1.7.0 an admin account which has already been compromised by an attacker may use a vulnerability in the `LESS` parser which can be exploited to read sensitive files on the server through the use of path traversal techniques. An attacker can achieve this by providing an absolute path to a sensitive file in the custom `LESS` setting, which the `LESS` parser will then read. For example, an attacker could use the following code to read the contents of the `/etc/passwd` file on a linux machine. The scope of what files are vulnerable will depend on the permissions given to the running flarum process. The vulnerability has been addressed in version `1.7`. Users should upgrade to this version to mitigate the vulnerability. Users unable to upgrade may mitigate the vulnerability by ensuring that their admin accounts are secured with strong passwords and follow other best practices for account security. Additionally, users can limit the exposure of sensitive files on the server by implementing appropriate file permissions and access controls at the operating system level.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| flarum | framework | before 1.7.0 | 1.7.0 | Patch available | CNA |
| — | flarum/core (Packagist) | before 1.7.0 | 1.7.0 | Patch available | GHSA-vhm8-wwrf-3gcw |
- framework Vendorflarum Affected before 1.7.0 Fixed in 1.7.0 Patch available CNA
- flarum/core (Packagist) Vendor— Affected before 1.7.0 Fixed in 1.7.0 Patch available GHSA-vhm8-wwrf-3gcw
Remediation
- Fix · CNA framework (flarum) Fixed in 1.7.0
- Fix · GHSA-vhm8-wwrf-3gcw flarum/core (Packagist) Fixed in 1.7.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-27577
- 2026-10-03 Alias added: GHSA-vhm8-wwrf-3gcw
References
Advisory 2
More Flarum vulnerabilities
- TI-2021-12339 XSS vulnerability with translator CVSS 3.1CRITICAL 10.0
- TI-2023-08736 Post mentions can be used to read any post on the forum without access control CVSS 3.1HIGH 7.7
- TI-2025-20573 Flarum Vulnerable to Session Hijacking via Authoritative Subdomain Cookie Overwrite CVSS 3.1MEDIUM 6.8
- TI-2022-20279 Cross site scripting vulnerability with discussion titles in flarum CVSS 3.1CRITICAL 9.0
- TI-2019-09878 Flarum before 0.1.0-beta.9 allows CSRF against all POST endpoints, as demonstrated by changing admin settings. CVSS 3.0HIGH 8.8
- TI-2019-08604 User/Command/ConfirmEmailHandler.php in Flarum before 0.1.0-beta.8 mishandles invalidation of user email tokens. CVSS 3.0HIGH 7.5
Sources
- CVE-2023-27577 · CVE Program
- CVE-2023-27577 · NVD
- FIRST EPSS
- GHSA-vhm8-wwrf-3gcw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences