Read the docs
TI-2023-12307 Aliases CVE-2023-27597

OpenSIPS has vulnerability in the parse_uri() function

Priority MEDIUM 40CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA.

Summary

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.8 and 3.2.5, when a specially crafted SIP message is processed by the function `rewrite_ruri`, a crash occurs due to a segmentation fault. This issue causes the server to crash. It affects configurations containing functions that make use of the affected code, such as the function `setport`. This issue has been fixed in version 3.1.8 and 3.2.5.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00738 54th percentileScored 2026-11-07
Fix Fixed opensips (OpenSIPS): 3.1.8, 3.2.5

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
OpenSIPSopensipsbefore 3.1.8; 3.2.0 to before 3.2.53.1.8, 3.2.5Patch availableCNA
  • opensips VendorOpenSIPS Affected before 3.1.8; 3.2.0 to before 3.2.5 Fixed in 3.1.8, 3.2.5 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:opensips:opensips:*:*:*:*:*:*:*:*before 3.1.8; 3.2.0 to before 3.2.5VulnerableOpenSIPS
  • cpe:2.3:a:opensips:opensips:*:*:*:*:*:*:*:* Versions before 3.1.8; 3.2.0 to before 3.2.5 Vulnerable ·OpenSIPS

Remediation

  • Fix · CNA opensips (OpenSIPS) Fixed in 3.1.8, 3.2.5

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-27597

References

  • TI-2023-12676 OpenSIPS has vulnerability in the Content-Length Parser CVSS 3.1HIGH 7.5
  • TI-2023-12674 OpenSIPS has vulnerability in the building the local negative replies CVSS 3.1HIGH 7.5
  • TI-2023-12311 OpenSIPS has vulnerability in the codec_delete_XX() functions CVSS 3.1HIGH 7.5
  • TI-2023-12310 OpenSIPS has vulnerability in the codec_delete_XX() functions CVSS 3.1HIGH 7.5
  • TI-2023-12309 OpenSIPS has vulnerability in the parse_to_param() function CVSS 3.1HIGH 7.5
  • TI-2023-12308 OpenSIPS has vulnerability in the parse_via() function CVSS 3.1HIGH 7.5
See all 11 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences