Read the docs
TI-2023-12309 Aliases CVE-2023-27599

OpenSIPS has vulnerability in the parse_to_param() function

Priority MEDIUM 41CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA.

Summary

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.7 and 3.2.4, when the function `append_hf` handles a SIP message with a malformed To header, a call to the function `abort()` is performed, resulting in a crash. This is due to the following check in `data_lump.c:399` in the function `anchor_lump`. An attacker abusing this vulnerability will crash OpenSIPS leading to Denial of Service. It affects configurations containing functions that make use of the affected code, such as the function `append_hf`. This issue has been fixed in versions 3.1.7 and 3.2.4.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00971 62nd percentileScored 2026-11-07
Fix Fixed opensips (OpenSIPS): 3.1.7, 3.2.4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
OpenSIPSopensipsbefore 3.1.7; 3.2.0 to before 3.2.43.1.7, 3.2.4Patch availableCNA
  • opensips VendorOpenSIPS Affected before 3.1.7; 3.2.0 to before 3.2.4 Fixed in 3.1.7, 3.2.4 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:opensips:opensips:*:*:*:*:*:*:*:*before 3.1.7; 3.2.0 to before 3.2.4VulnerableOpenSIPS
  • cpe:2.3:a:opensips:opensips:*:*:*:*:*:*:*:* Versions before 3.1.7; 3.2.0 to before 3.2.4 Vulnerable ·OpenSIPS

Remediation

  • Fix · CNA opensips (OpenSIPS) Fixed in 3.1.7, 3.2.4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-27599

References

  • TI-2023-12676 OpenSIPS has vulnerability in the Content-Length Parser CVSS 3.1HIGH 7.5
  • TI-2023-12674 OpenSIPS has vulnerability in the building the local negative replies CVSS 3.1HIGH 7.5
  • TI-2023-12311 OpenSIPS has vulnerability in the codec_delete_XX() functions CVSS 3.1HIGH 7.5
  • TI-2023-12310 OpenSIPS has vulnerability in the codec_delete_XX() functions CVSS 3.1HIGH 7.5
  • TI-2023-12308 OpenSIPS has vulnerability in the parse_via() function CVSS 3.1HIGH 7.5
  • TI-2023-12307 OpenSIPS has vulnerability in the parse_uri() function CVSS 3.1HIGH 7.5
See all 11 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences