Cross-site scripting in Jenkins
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 2 fixed, 1 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
Jenkins 2.270 through 2.393 (both inclusive), LTS 2.277.1 through 2.375.3 (both inclusive) does not escape the Jenkins version a plugin depends on when rendering the error message stating its incompatibility with the current version of Jenkins, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide plugins to the configured update sites and have this message shown by Jenkins instances.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins | 2.270 and later | — | No fix listed | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 2.376 to before 2.394 | 2.394 | Patch available | GHSA-j664-qhh4-hpf8 |
| — | org.jenkins-ci.main:jenkins-core (Maven) | before 2.375.4 | 2.375.4 | Patch available | GHSA-j664-qhh4-hpf8 |
- Jenkins VendorJenkins Affected 2.270 and later Fixed in — No fix listed CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.376 to before 2.394 Fixed in 2.394 Patch available GHSA-j664-qhh4-hpf8
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.375.4 Fixed in 2.375.4 Patch available GHSA-j664-qhh4-hpf8
Remediation
- Fix · GHSA-j664-qhh4-hpf8 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.394 Advisory →
- Fix · GHSA-j664-qhh4-hpf8 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.375.4 Advisory →
Red Hat 2 advisories
- RHSA-2023:3663 Released 2023-06-19 · Red Hat rating Importantjenkins and jenkins-2-plugins security update
- OpenShift Developer Tools and Services for OCP 4.11 for RHEL 8 jenkins-2-plugins-4.11.1686831822-1.el8, jenkins-2.401.1.1686831596-3.el8
- RHSA-2023:1655 Released 2023-04-12 · Red Hat rating CriticalOpenShift Container Platform 4.10.56 security update
- Red Hat OpenShift Container Platform 4.10 haproxy-2.2.19-4.el8, haproxy22-2.2.19-4.el8, jenkins-2-plugins-4.10.1680703106-1.el8 +5
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Jenkins — Jenkins Security Advisory 2023-03-08
7 records Highest priority Priority MEDIUM 1 MEDIUM, 6 LOW
Other records, highest priority first
- TI-2023-12492 Resource allocation without limits in JenkinsPriority LOW 35
- TI-2023-12491 Resource allocation without limits in JenkinsPriority LOW 35
- TI-2023-12490 Incorrect authorization in JenkinsPriority LOW 32
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.11 | Affected | No fix planned: Out of support scope |
| OpenShift Developer Tools and Services for OCP 4.11 for RHEL 8 | Fixed | RHSA-2023:3663 |
| Red Hat OpenShift Container Platform 4.10 | Fixed | RHSA-2023:1655 |
Not affected: 2 products
- OpenShift Developer Tools and Services for OCP 4.11 for RHEL 8
- Red Hat OpenShift Container Platform 4.10
Timeline
- 2026-10-02 Threatist record created from CVE-2023-27898
- 2026-10-03 Alias added: GHSA-j664-qhh4-hpf8
References
More Jenkins vulnerabilities
- TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
- TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2023-27898 · CVE Program
- CVE-2023-27898 · NVD
- FIRST EPSS
- GHSA-j664-qhh4-hpf8 · GitHub Advisory Database · CC BY 4.0
- CVE-2023-27898 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences