emacsclient-mail.desktop in Emacs 28.1 through 28.2 is vulnerable to shell command…
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-78.
Summary
emacsclient-mail.desktop in Emacs 28.1 through 28.2 is vulnerable to shell command injections through a crafted mailto: URI. This is related to lack of compliance with the Desktop Entry Specification. It is fixed in 29.0.90
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2023-27985
- 2026-10-03 Alias added: GHSA-f5fq-43fc-vgcr
References
Patch 4
- https://www.openwall.com/lists/oss-security/2023/03/08/2
- http://git.savannah.gnu.org/cgit/emacs.git/commit/?h=emacs-29&id=d32091199ae5de590a83f1542a01d75fba000467
- https://debbugs.gnu.org/cgi/bugreport.cgi?bug=60204
- [oss-security] 20230309 Re: Shell command and Emacs Lisp code injection in emacsclient-mail.desktop
More GNU Emacs vulnerabilities
- TI-2024-36089 In elisp-mode.el in GNU Emacs before 30.1, a user who chooses to invoke… CVSS 3.1HIGH 7.8
- TI-2023-12576 emacsclient-mail.desktop in Emacs 28.1 through 28.2 is vulnerable to Emacs Lisp code… CVSS 3.1HIGH 7.8
- TI-2022-23951 GNU Emacs through 28.2 allows attackers to execute commands via shell metacharacters in… CVSS 3.1CRITICAL 9.8
- TI-2024-26287 In Emacs before 29.4, org-link-expand-abbrev in lisp/ol.el expands a %(...) link abbrev… CVSS 3.1CRITICAL 9.8
- TI-2007-05829 Stack-based buffer overflow in emacs allows user-assisted attackers to cause a denial of… CVSS 2.0HIGH 10.0
- TI-2017-10588 GNU Emacs before 25.3 allows remote attackers to execute arbitrary code via email with… CVSS 3.0HIGH 8.8
Sources
- CVE-2023-27985 · CVE Program
- CVE-2023-27985 · NVD
- FIRST EPSS
- GHSA-f5fq-43fc-vgcr · GitHub Advisory Database · CC BY 4.0
- CVE-2023-27985 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences