Read the docs
TI-2023-12675 Aliases CVE-2023-28096

OpenSIPS has memory leak in cJSON lib

Priority LOW 34CWE-401Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-401.

Summary

OpenSIPS, a Session Initiation Protocol (SIP) server implementation, has a memory leak starting in the 2.3 branch and priot to versions 3.1.8 and 3.2.5. The memory leak was detected in the function `parse_mi_request` while performing coverage-guided fuzzing. This issue can be reproduced by sending multiple requests of the form `{"jsonrpc": "2.0","method": "log_le`. This malformed message was tested against an instance of OpenSIPS via FIFO transport layer and was found to increase the memory consumption over time. To abuse this memory leak, attackers need to reach the management interface (MI) which typically should only be exposed on trusted interfaces. In cases where the MI is exposed to the internet without authentication, abuse of this issue will lead to memory exhaustion which may affect the underlying system’s availability. No authentication is typically required to reproduce this issue. On the other hand, memory leaks may occur in other areas of OpenSIPS where the cJSON library is used for parsing JSON objects. The issue has been fixed in versions 3.1.8 and 3.2.5.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00767 55th percentileScored 2026-11-07
Fix Fixed opensips (OpenSIPS): 3.1.8, 3.2.5

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
OpenSIPSopensips2.3.0 to before 3.1.8; 3.2.0 to before 3.2.53.1.8, 3.2.5Patch availableCNA
  • opensips VendorOpenSIPS Affected 2.3.0 to before 3.1.8; 3.2.0 to before 3.2.5 Fixed in 3.1.8, 3.2.5 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:opensips:opensips:*:*:*:*:*:*:*:*before 3.1.8; 3.2.0 to before 3.2.5VulnerableOpenSIPS
  • cpe:2.3:a:opensips:opensips:*:*:*:*:*:*:*:* Versions before 3.1.8; 3.2.0 to before 3.2.5 Vulnerable ·OpenSIPS

Remediation

  • Fix · CNA opensips (OpenSIPS) Fixed in 3.1.8, 3.2.5

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-28096

References

  • TI-2023-12676 OpenSIPS has vulnerability in the Content-Length Parser CVSS 3.1HIGH 7.5
  • TI-2023-12674 OpenSIPS has vulnerability in the building the local negative replies CVSS 3.1HIGH 7.5
  • TI-2023-12311 OpenSIPS has vulnerability in the codec_delete_XX() functions CVSS 3.1HIGH 7.5
  • TI-2023-12310 OpenSIPS has vulnerability in the codec_delete_XX() functions CVSS 3.1HIGH 7.5
  • TI-2023-12309 OpenSIPS has vulnerability in the parse_to_param() function CVSS 3.1HIGH 7.5
  • TI-2023-12308 OpenSIPS has vulnerability in the parse_via() function CVSS 3.1HIGH 7.5
See all 11 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences