silverstripe/graphql Denial of Service vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-770.
Summary
`silverstripe/graphql` serves Silverstripe data as GraphQL representations. In versions 4.2.2 and 4.1.1, an attacker could use a specially crafted graphql query to execute a denial of service attack against a website which has a publicly exposed graphql endpoint. This mostly affects websites with particularly large/complex graphql schemas. Users should upgrade to `silverstripe/graphql` 4.2.3 or 4.1.2 to remedy the vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| silverstripe | silverstripe-graphql | = 4.1.1; = 4.2.2 | — | No fix listed | CNA |
| — | silverstripe/graphql (Packagist) | 4.1.1 to before 4.1.2 | 4.1.2 | Patch available | GHSA-67g8-c724-8mp3 |
| — | silverstripe/graphql (Packagist) | 4.2.2 to before 4.2.3 | 4.2.3 | Patch available | GHSA-67g8-c724-8mp3 |
- silverstripe-graphql Vendorsilverstripe Affected = 4.1.1; = 4.2.2 Fixed in — No fix listed CNA
- silverstripe/graphql (Packagist) Vendor— Affected 4.1.1 to before 4.1.2 Fixed in 4.1.2 Patch available GHSA-67g8-c724-8mp3
- silverstripe/graphql (Packagist) Vendor— Affected 4.2.2 to before 4.2.3 Fixed in 4.2.3 Patch available GHSA-67g8-c724-8mp3
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:silverstripe:graphql:4.1.1:*:*:*:*:*:*:* | 4.1.1 | Vulnerable | silverstripe |
| cpe:2.3:a:silverstripe:graphql:4.2.2:*:*:*:*:*:*:* | 4.2.2 | Vulnerable | silverstripe |
- cpe:2.3:a:silverstripe:graphql:4.1.1:*:*:*:*:*:*:* Versions 4.1.1 Vulnerable ·silverstripe
- cpe:2.3:a:silverstripe:graphql:4.2.2:*:*:*:*:*:*:* Versions 4.2.2 Vulnerable ·silverstripe
Remediation
- Fix · GHSA-67g8-c724-8mp3 silverstripe/graphql (Packagist) Fixed in 4.1.2 Advisory →
- Fix · GHSA-67g8-c724-8mp3 silverstripe/graphql (Packagist) Fixed in 4.2.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-28104
- 2026-10-03 Alias added: GHSA-67g8-c724-8mp3
References
Patch 3
Advisory 2
More silverstripe Graphql vulnerabilities
- TI-2023-21053 Denial of service vulnerability in silverstripe-graphql via recursive queries CVSS 3.1HIGH 7.5
- TI-2023-23907 Silverstripe GraqhQL's view permissions are bypassed for paginated lists of ORM data CVSS 3.1MEDIUM 5.3
Sources
- CVE-2023-28104 · CVE Program
- CVE-2023-28104 · NVD
- FIRST EPSS
- GHSA-67g8-c724-8mp3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences