Denial of service vulnerability in silverstripe-graphql via recursive queries
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
silverstripe-graphql is a package which serves Silverstripe data in GraphQL representations. An attacker could use a recursive graphql query to execute a Distributed Denial of Service attack (DDOS attack) against a website. This mostly affects websites with publicly exposed graphql schemas. If your Silverstripe CMS project does not expose a public facing graphql schema, a user account is required to trigger the DDOS attack. If your site is hosted behind a content delivery network (CDN), such as Imperva or CloudFlare, this may further mitigate the risk. This issue has been addressed in versions 3.8.2, 4.1.3, 4.2.5, 4.3.4, and 5.0.3. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| silverstripe | silverstripe-graphql | 3.0.0 to before 3.8.2; 4.0.0 to before 4.1.3; 4.2.0 to before 4.2.5; 4.3.0 to before 4.3.4; 5.0.0 to before 5.0.3 | 3.8.2, 4.1.3, 4.2.5, 4.3.4, 5.0.3 | Patch available | CNA |
| — | silverstripe/graphql (Packagist) | 3.0.0 to before 3.8.2 | 3.8.2 | Patch available | GHSA-v23w-pppm-jh66 |
| — | silverstripe/graphql (Packagist) | 4.0.0 to before 4.1.3 | 4.1.3 | Patch available | GHSA-v23w-pppm-jh66 |
| — | silverstripe/graphql (Packagist) | 4.2.0 to before 4.2.5 | 4.2.5 | Patch available | GHSA-v23w-pppm-jh66 |
| — | silverstripe/graphql (Packagist) | 4.3.0 to before 4.3.4 | 4.3.4 | Patch available | GHSA-v23w-pppm-jh66 |
| — | silverstripe/graphql (Packagist) | 5.0.0 to before 5.0.3 | 5.0.3 | Patch available | GHSA-v23w-pppm-jh66 |
- silverstripe-graphql Vendorsilverstripe Affected 3.0.0 to before 3.8.2; 4.0.0 to before 4.1.3; 4.2.0 to before 4.2.5; 4.3.0 to before 4.3.4; 5.0.0 to before 5.0.3 Fixed in 3.8.2, 4.1.3, 4.2.5, 4.3.4, 5.0.3 Patch available CNA
- silverstripe/graphql (Packagist) Vendor— Affected 3.0.0 to before 3.8.2 Fixed in 3.8.2 Patch available GHSA-v23w-pppm-jh66
- silverstripe/graphql (Packagist) Vendor— Affected 4.0.0 to before 4.1.3 Fixed in 4.1.3 Patch available GHSA-v23w-pppm-jh66
- silverstripe/graphql (Packagist) Vendor— Affected 4.2.0 to before 4.2.5 Fixed in 4.2.5 Patch available GHSA-v23w-pppm-jh66
- silverstripe/graphql (Packagist) Vendor— Affected 4.3.0 to before 4.3.4 Fixed in 4.3.4 Patch available GHSA-v23w-pppm-jh66
- silverstripe/graphql (Packagist) Vendor— Affected 5.0.0 to before 5.0.3 Fixed in 5.0.3 Patch available GHSA-v23w-pppm-jh66
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:silverstripe:graphql:*:*:*:*:*:*:*:* | 3.0.0 to before 3.8.2; 4.0.0 to before 4.1.3; 4.2.0 to before 4.2.5; 4.3.0 to before 4.3.4; 5.0.0 to before 5.0.3 | Vulnerable | silverstripe |
- cpe:2.3:a:silverstripe:graphql:*:*:*:*:*:*:*:* Versions 3.0.0 to before 3.8.2; 4.0.0 to before 4.1.3; 4.2.0 to before 4.2.5; 4.3.0 to before 4.3.4; 5.0.0 to before 5.0.3 Vulnerable ·silverstripe
Remediation
- Fix · CNA silverstripe-graphql (silverstripe) Fixed in 3.8.2, 4.1.3, 4.2.5, 4.3.4, 5.0.3
- Fix · GHSA-v23w-pppm-jh66 silverstripe/graphql (Packagist) Fixed in 3.8.2 Advisory →
- Fix · GHSA-v23w-pppm-jh66 silverstripe/graphql (Packagist) Fixed in 4.1.3 Advisory →
- Fix · GHSA-v23w-pppm-jh66 silverstripe/graphql (Packagist) Fixed in 4.2.5 Advisory →
- Fix · GHSA-v23w-pppm-jh66 silverstripe/graphql (Packagist) Fixed in 4.3.4 Advisory →
- Fix · GHSA-v23w-pppm-jh66 silverstripe/graphql (Packagist) Fixed in 5.0.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-40180
- 2026-10-03 Alias added: GHSA-v23w-pppm-jh66
References
Patch 1
Advisory 4
More silverstripe Graphql vulnerabilities
- TI-2023-12683 silverstripe/graphql Denial of Service vulnerability CVSS 3.1HIGH 7.5
- TI-2023-23907 Silverstripe GraqhQL's view permissions are bypassed for paginated lists of ORM data CVSS 3.1MEDIUM 5.3
Sources
- CVE-2023-40180 · CVE Program
- CVE-2023-40180 · NVD
- FIRST EPSS
- GHSA-v23w-pppm-jh66 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences