Improper authentication in WooCommerce Payments WordPress Plugin
Priority HIGH 84CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-287.
Summary
An issue in WooCommerce Payments plugin for WordPress (versions 5.6.1 and lower) allows an unauthenticated attacker to send requests on behalf of an elevated user, like administrator. This allows a remote, unauthenticated attacker to gain admin access on a site that has the affected version of the plugin activated.
Why it matters now
EPSS 0.87448 99th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | WooCommerce Payments WordPress Plugin | Fixed version 5.6.2 | — | No fix listed | CNA |
- WooCommerce Payments WordPress Plugin Vendor— Affected Fixed version 5.6.2 Fixed in — No fix listed CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:automattic:woocommerce_payments:*:*:*:*:*:wordpress:*:* | 4.8.0 to before 4.8.2; 5.0.0 to before 5.0.4; 5.1.0 to before 5.1.3; 5.2.0 to before 5.2.2; 5.5.0 to before 5.5.2 | Vulnerable | Automattic |
| cpe:2.3:a:automattic:woopayments:*:*:*:*:*:wordpress:*:* | 5.6.0 to before 5.6.2 | Vulnerable | Automattic |
| cpe:2.3:a:automattic:woopayments:4.9.0:*:*:*:*:wordpress:*:* | 4.9.0 | Vulnerable | Automattic |
| cpe:2.3:a:automattic:woopayments:5.3.0:*:*:*:*:wordpress:*:* | 5.3.0 | Vulnerable | Automattic |
| cpe:2.3:a:automattic:woopayments:5.4.0:*:*:*:*:wordpress:*:* | 5.4.0 | Vulnerable | Automattic |
- cpe:2.3:a:automattic:woocommerce_payments:*:*:*:*:*:wordpress:*:* Versions 4.8.0 to before 4.8.2; 5.0.0 to before 5.0.4; 5.1.0 to before 5.1.3; 5.2.0 to before 5.2.2; 5.5.0 to before 5.5.2 Vulnerable ·Automattic
- cpe:2.3:a:automattic:woopayments:*:*:*:*:*:wordpress:*:* Versions 5.6.0 to before 5.6.2 Vulnerable ·Automattic
- cpe:2.3:a:automattic:woopayments:4.9.0:*:*:*:*:wordpress:*:* Versions 4.9.0 Vulnerable ·Automattic
- cpe:2.3:a:automattic:woopayments:5.3.0:*:*:*:*:wordpress:*:* Versions 5.3.0 Vulnerable ·Automattic
- cpe:2.3:a:automattic:woopayments:5.4.0:*:*:*:*:wordpress:*:* Versions 5.4.0 Vulnerable ·Automattic
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2023-28121
- 2026-10-03 Alias added: GHSA-rw6j-4w4v-pm7m
References
Sources
- CVE-2023-28121 · CVE Program
- CVE-2023-28121 · NVD
- FIRST EPSS
- GHSA-rw6j-4w4v-pm7m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences