Moodle: teacher can access names of users they do not have permission to access
Priority LOW 21CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Insufficient filtering of grade report history made it possible for teachers to access the names of users they could not otherwise access.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00742 54th percentileScored 2026-11-07
Fix Fixed moodle: 4.1.2, 4.0.7, 3.11.13 +1moodle/moodle (Packagist): 4.1.2, 4.0.7, 3.11.13 +1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 4.1.0 to before 4.1.2; 4.0.0 to before 4.0.7; 3.11.0 to before 3.11.13; before 3.9.20 | 4.1.2, 4.0.7, 3.11.13, 3.9.20 | Patch available | CNA |
| — | moodle/moodle (Packagist) | 4.1.0 to before 4.1.2 | 4.1.2 | Patch available | GHSA-prjm-2fj2-787f |
| — | moodle/moodle (Packagist) | 4.0.0 to before 4.0.7 | 4.0.7 | Patch available | GHSA-prjm-2fj2-787f |
| — | moodle/moodle (Packagist) | 3.11.0 to before 3.11.13 | 3.11.13 | Patch available | GHSA-prjm-2fj2-787f |
| — | moodle/moodle (Packagist) | before 3.9.20 | 3.9.20 | Patch available | GHSA-prjm-2fj2-787f |
- moodle Vendor— Affected 4.1.0 to before 4.1.2; 4.0.0 to before 4.0.7; 3.11.0 to before 3.11.13; before 3.9.20 Fixed in 4.1.2, 4.0.7, 3.11.13, 3.9.20 Patch available CNA
- moodle/moodle (Packagist) Vendor— Affected 4.1.0 to before 4.1.2 Fixed in 4.1.2 Patch available GHSA-prjm-2fj2-787f
- moodle/moodle (Packagist) Vendor— Affected 4.0.0 to before 4.0.7 Fixed in 4.0.7 Patch available GHSA-prjm-2fj2-787f
- moodle/moodle (Packagist) Vendor— Affected 3.11.0 to before 3.11.13 Fixed in 3.11.13 Patch available GHSA-prjm-2fj2-787f
- moodle/moodle (Packagist) Vendor— Affected before 3.9.20 Fixed in 3.9.20 Patch available GHSA-prjm-2fj2-787f
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | after 3.9.0, before 3.9.20; after 3.11.0, before 3.11.13; after 4.0.0, before 4.0.7 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.9.0:-:*:*:*:*:*:* | 3.9.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.11.0:-:*:*:*:*:*:* | 3.11.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:4.0.0:-:*:*:*:*:*:* | 4.0.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:4.1.0:-:*:*:*:*:*:* | 4.1.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:4.1.1:*:*:*:*:*:*:* | 4.1.1 | Vulnerable | Moodle |
| cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* | 36 | Vulnerable | Fedoraproject |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions after 3.9.0, before 3.9.20; after 3.11.0, before 3.11.13; after 4.0.0, before 4.0.7 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.9.0:-:*:*:*:*:*:* Versions 3.9.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.11.0:-:*:*:*:*:*:* Versions 3.11.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:4.0.0:-:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:4.1.0:-:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:4.1.1:*:*:*:*:*:*:* Versions 4.1.1 Vulnerable ·Moodle
- cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* Versions 36 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA moodle Fixed in 4.1.2, 4.0.7, 3.11.13, 3.9.20
- Fix · GHSA-prjm-2fj2-787f moodle/moodle (Packagist) Fixed in 4.1.2 Advisory →
- Fix · GHSA-prjm-2fj2-787f moodle/moodle (Packagist) Fixed in 4.0.7 Advisory →
- Fix · GHSA-prjm-2fj2-787f moodle/moodle (Packagist) Fixed in 3.11.13 Advisory →
- Fix · GHSA-prjm-2fj2-787f moodle/moodle (Packagist) Fixed in 3.9.20 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2023-28336
- 2026-10-03 Alias added: GHSA-prjm-2fj2-787f
References
Other 6
- RHBZ#2179426
- https://github.com/moodle/moodle/commit/a931a7f8cec3657827268837b27962a13817ca2b
- https://git.moodle.org/gw?p=moodle.git;a=commit;h=a931a7f8cec3657827268837b27962a13817ca2b
- https://github.com/moodle/moodle
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3QZN34VSF4HTCW3C3ZP2OZYSLYUKADPF
- https://lists.fedoraproject.org/archives/list/[email protected]/message/3QZN34VSF4HTCW3C3ZP2OZYSLYUKADPF
Sources
- CVE-2023-28336 · CVE Program
- CVE-2023-28336 · NVD
- FIRST EPSS
- GHSA-prjm-2fj2-787f · GitHub Advisory Database · CC BY 4.0
- CVE-2023-28336 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences