api/auth.go in Ansible Semaphore before 2.8.89 mishandles authentication.
Priority MEDIUM 44CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
api/auth.go in Ansible Semaphore before 2.8.89 mishandles authentication.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00873 59th percentileScored 2026-11-07
Fix Fixed github.com/ansible-semaphore/semaphore (Go): 2.8.89
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | github.com/ansible-semaphore/semaphore (Go) | before 2.8.89 | 2.8.89 | Patch available | GHSA-pmhg-cmjc-3875 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- github.com/ansible-semaphore/semaphore (Go) Vendor— Affected before 2.8.89 Fixed in 2.8.89 Patch available GHSA-pmhg-cmjc-3875
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ansible-semaphore:ansible_semaphore:*:*:*:*:*:ansible:*:* | before 2.8.89 | Vulnerable | Ansible-semaphore |
- cpe:2.3:a:ansible-semaphore:ansible_semaphore:*:*:*:*:*:ansible:*:* Versions before 2.8.89 Vulnerable ·Ansible-semaphore
Remediation
- Fix · GHSA-pmhg-cmjc-3875 github.com/ansible-semaphore/semaphore (Go) Fixed in 2.8.89 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-28609
- 2026-10-03 Alias added: GHSA-pmhg-cmjc-3875
References
More Ansible-semaphore Ansible Semaphore vulnerabilities
- TI-2023-20278 An issue in ansible semaphore v.2.8.90 allows a remote attacker to execute arbitrary code… CVSS 3.1HIGH 8.8
Sources
- CVE-2023-28609 · CVE Program
- CVE-2023-28609 · NVD
- FIRST EPSS
- GHSA-pmhg-cmjc-3875 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences