Airflow Apache Drill Provider Arbitrary File Read Vulnerability
Priority MEDIUM 43CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.
Summary
Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Drill Provider.This issue affects Apache Airflow Drill Provider: before 2.3.2.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.02062 81st percentileScored 2026-11-07
Fix Fixed Apache Airflow Drill Provider (Apache Software Foundation): 2.3.2apache-airflow-providers-apache-drill (PyPI): 2.3.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Airflow Drill Provider | before 2.3.2 | 2.3.2 | Patch available | CNA |
| — | apache-airflow-providers-apache-drill (PyPI) | before 2.3.2 | 2.3.2 | Patch available | GHSA-85pf-r4c7-3j9r |
- Apache Airflow Drill Provider VendorApache Affected before 2.3.2 Fixed in 2.3.2 Patch available CNA
- apache-airflow-providers-apache-drill (PyPI) Vendor— Affected before 2.3.2 Fixed in 2.3.2 Patch available GHSA-85pf-r4c7-3j9r
Remediation
- Fix · CNA Apache Airflow Drill Provider (Apache Software Foundation) Fixed in 2.3.2
- Fix · GHSA-85pf-r4c7-3j9r apache-airflow-providers-apache-drill (PyPI) Fixed in 2.3.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-28707
- 2026-10-03 Alias added: GHSA-85pf-r4c7-3j9r
References
Advisory 3
More Apache-airflow-providers-apache-drill vulnerabilities
- TI-2023-20684 Apache Airflow Drill Provider Arbitrary File Read Vulnerability CVSS 3.1HIGH 7.5
Sources
- CVE-2023-28707 · CVE Program
- CVE-2023-28707 · NVD
- FIRST EPSS
- GHSA-85pf-r4c7-3j9r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences