Apache Airflow Drill Provider Arbitrary File Read Vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.
Summary
Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Drill Provider. Apache Airflow Drill Provider is affected by a vulnerability that allows an attacker to pass in malicious parameters when establishing a connection with DrillHook giving an opportunity to read files on the Airflow server. This issue affects Apache Airflow Drill Provider: before 2.4.3. It is recommended to upgrade to a version that is not affected.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Airflow Drill Provider | before 2.4.3 | 2.4.3 | Patch available | CNA |
| — | apache-airflow-providers-apache-drill (PyPI) | before 2.4.3 | 2.4.3 | Patch available | GHSA-mq4v-6vg4-796c |
- Apache Airflow Drill Provider VendorApache Affected before 2.4.3 Fixed in 2.4.3 Patch available CNA
- apache-airflow-providers-apache-drill (PyPI) Vendor— Affected before 2.4.3 Fixed in 2.4.3 Patch available GHSA-mq4v-6vg4-796c
Remediation
- Fix · CNA Apache Airflow Drill Provider (Apache Software Foundation) Fixed in 2.4.3
- Fix · GHSA-mq4v-6vg4-796c apache-airflow-providers-apache-drill (PyPI) Fixed in 2.4.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-39553
- 2026-10-03 Alias added: GHSA-mq4v-6vg4-796c
References
Patch 3
More Apache-airflow-providers-apache-drill vulnerabilities
- TI-2023-13224 Airflow Apache Drill Provider Arbitrary File Read Vulnerability CVSS 3.1HIGH 7.5
Sources
- CVE-2023-39553 · CVE Program
- CVE-2023-39553 · NVD
- FIRST EPSS
- GHSA-mq4v-6vg4-796c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences