imgproxy <=3.14.0 is vulnerable to Server-Side Request Forgery (SSRF) due to a lack of…
Priority LOW 34CWE-918Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-918 and the CVSS impact.
Summary
imgproxy <=3.14.0 is vulnerable to Server-Side Request Forgery (SSRF) due to a lack of sanitization of the imageURL parameter.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.02214 82nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed github.com/imgproxy/imgproxy/v3 (Go): 3.15.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | github.com/imgproxy/imgproxy/v3 (Go) | before 3.15.0 | 3.15.0 | Patch available | GHSA-9x7h-ggc3-xg47 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- github.com/imgproxy/imgproxy/v3 (Go) Vendor— Affected before 3.15.0 Fixed in 3.15.0 Patch available GHSA-9x7h-ggc3-xg47
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:evilmartians:imgproxy:*:*:*:*:*:*:*:* | up to 3.14.0 | Vulnerable | Evilmartians |
- cpe:2.3:a:evilmartians:imgproxy:*:*:*:*:*:*:*:* Versions up to 3.14.0 Vulnerable ·Evilmartians
Remediation
- Fix · GHSA-9x7h-ggc3-xg47 github.com/imgproxy/imgproxy/v3 (Go) Fixed in 3.15.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-30019
- 2026-10-03 Alias added: GHSA-9x7h-ggc3-xg47
References
More Evilmartians Imgproxy vulnerabilities
- TI-2023-01415 Cross-site Scripting (XSS) - Reflected in imgproxy/imgproxy CVSS 3.1MEDIUM 5.4
Sources
- CVE-2023-30019 · CVE Program
- CVE-2023-30019 · NVD
- FIRST EPSS
- GHSA-9x7h-ggc3-xg47 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences