Command injection vulnerability in RaspAP raspap-webgui 2.8.8 and earlier allows remote…
Priority MEDIUM 45CWE-77Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-77.
Summary
Command injection vulnerability in RaspAP raspap-webgui 2.8.8 and earlier allows remote attackers to run arbitrary commands via crafted POST request to hostapd settings form.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.02484 84th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed billz/raspap-webgui (Packagist): 2.8.9
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | billz/raspap-webgui (Packagist) | before 2.8.9 | 2.8.9 | Patch available | GHSA-hhqm-f4m4-pq39 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- billz/raspap-webgui (Packagist) Vendor— Affected before 2.8.9 Fixed in 2.8.9 Patch available GHSA-hhqm-f4m4-pq39
Remediation
- Fix · GHSA-hhqm-f4m4-pq39 billz/raspap-webgui (Packagist) Fixed in 2.8.9 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-30260
- 2026-10-03 Alias added: GHSA-hhqm-f4m4-pq39
References
More Raspap vulnerabilities
- TI-2022-18933 A Command injection vulnerability in RaspAP 2.8.0 thru 2.8.7 allows unauthenticated… CVSS 3.1CRITICAL 9.8
- TI-2022-18934 A Command injection vulnerability in RaspAP 2.8.0 thru 2.9.2 allows an authenticated… CVSS 3.1HIGH 8.8
- TI-2024-02323 RaspAP raspap-webgui HTTP POST Request provider.php code injection CVSS 3.1HIGH 7.2
- TI-2021-12821 A vulnerability exists in RaspAP 2.6 to 2.6.5 in the "iface" GET parameter in… CVSS 3.1CRITICAL 9.8
- TI-2021-16152 includes/configure_client.php in RaspAP 2.6.6 allows attackers to execute commands via command injection. CVSS 3.1HIGH 8.8
- TI-2020-15053 An issue was discovered in includes/webconsole.php in RaspAP 2.5. CVSS 3.1HIGH 8.8
Sources
- CVE-2023-30260 · CVE Program
- CVE-2023-30260 · NVD
- FIRST EPSS
- GHSA-hhqm-f4m4-pq39 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences