Read the docs
TI-2023-14383 Aliases CVE-2023-30548GHSA-h2pm-378c-pcxx

Path traversal vulnerability in gatsby-plugin-sharp

Priority MEDIUM 53CWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.

Summary

gatsby-plugin-sharp is a plugin for the gatsby framework which exposes functions built on the Sharp image processing library. The gatsby-plugin-sharp plugin prior to versions 5.8.1 and 4.25.1 contains a path traversal vulnerability exposed when running the Gatsby develop server (`gatsby develop`). It should be noted that by default gatsby develop is only accessible via the localhost 127.0.0.1, and one would need to intentionally expose the server to other interfaces to exploit this vulnerability by using server options such as --host 0.0.0.0, -H 0.0.0.0, or the GATSBY_HOST=0.0.0.0 environment variable. Attackers exploiting this vulnerability will have read access to all files within the scope of the server process. A patch has been introduced in [email protected] and [email protected] which mitigates the issue by ensuring that included paths remain within the project directory. As stated above, by default gatsby develop is only exposed to the localhost 127.0.0.1. For those using the develop server in the default configuration no risk is posed. If other ranges are required, preventing the develop server from being exposed to untrusted interfaces or IP address ranges would mitigate the risk from this vulnerability. Users are non the less encouraged to upgrade to a safe version.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00882 59th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed gatsby (gatsbyjs): 4.25.1, 5.8.1gatsby-plugin-sharp (npm): 5.8.1, 4.25.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
gatsbyjsgatsbybefore 4.25.1; 5.0.0 to before 5.8.14.25.1, 5.8.1Patch availableCNA
—gatsby-plugin-sharp (npm)5.0.0 to before 5.8.15.8.1Patch availableGHSA-h2pm-378c-pcxx
—gatsby-plugin-sharp (npm)before 4.25.14.25.1Patch availableGHSA-h2pm-378c-pcxx
  • gatsby Vendorgatsbyjs Affected before 4.25.1; 5.0.0 to before 5.8.1 Fixed in 4.25.1, 5.8.1 Patch available CNA
  • gatsby-plugin-sharp (npm) Vendor— Affected 5.0.0 to before 5.8.1 Fixed in 5.8.1 Patch available GHSA-h2pm-378c-pcxx
  • gatsby-plugin-sharp (npm) Vendor— Affected before 4.25.1 Fixed in 4.25.1 Patch available GHSA-h2pm-378c-pcxx

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:gatsbyjs:gatsby-plugin-sharp:*:*:*:*:*:node.js:*:*before 4.25.1; 5.0.0 to before 5.8.1Vulnerablegatsbyjs
  • cpe:2.3:a:gatsbyjs:gatsby-plugin-sharp:*:*:*:*:*:node.js:*:* Versions before 4.25.1; 5.0.0 to before 5.8.1 Vulnerable ·gatsbyjs

Remediation

  • Fix · CNA gatsby (gatsbyjs) Fixed in 4.25.1, 5.8.1
  • Fix · GHSA-h2pm-378c-pcxx gatsby-plugin-sharp (npm) Fixed in 5.8.1 Advisory →
  • Fix · GHSA-h2pm-378c-pcxx gatsby-plugin-sharp (npm) Fixed in 4.25.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-30548
  2. 2026-10-03 Alias added: GHSA-h2pm-378c-pcxx

References

Sources