Apache Cassandra: Privilege escalation when enabling FQL/Audit logs
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-269.
Summary
Privilege escalation when enabling FQL/Audit logs allows user with JMX access to run arbitrary commands as the user running Apache Cassandra This issue affects Apache Cassandra: from 4.0.0 through 4.0.9, from 4.1.0 through 4.1.1. WORKAROUND The vulnerability requires nodetool/JMX access to be exploitable, disable access for any non-trusted users. MITIGATION Upgrade to 4.0.10 or 4.1.2 and leave the new FQL/Auditlog configuration property allow_nodetool_archive_command as false.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Cassandra | 4.0.0 – 4.0.9; 4.1.0 – 4.1.1 | — | No fix listed | CNA |
| — | org.apache.cassandra:cassandra-all (Maven) | 4.1.0 to before 4.1.2 | 4.1.2 | Patch available | GHSA-m9p2-j4hg-g373 |
| — | org.apache.cassandra:cassandra-all (Maven) | 4.0.0 to before 4.0.10 | 4.0.10 | Patch available | GHSA-m9p2-j4hg-g373 |
- Apache Cassandra VendorApache Affected 4.0.0 – 4.0.9; 4.1.0 – 4.1.1 Fixed in — No fix listed CNA
- org.apache.cassandra:cassandra-all (Maven) Vendor— Affected 4.1.0 to before 4.1.2 Fixed in 4.1.2 Patch available GHSA-m9p2-j4hg-g373
- org.apache.cassandra:cassandra-all (Maven) Vendor— Affected 4.0.0 to before 4.0.10 Fixed in 4.0.10 Patch available GHSA-m9p2-j4hg-g373
Remediation
- Fix · GHSA-m9p2-j4hg-g373 org.apache.cassandra:cassandra-all (Maven) Fixed in 4.1.2 Advisory →
- Fix · GHSA-m9p2-j4hg-g373 org.apache.cassandra:cassandra-all (Maven) Fixed in 4.0.10 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-30601
- 2026-10-03 Alias added: GHSA-m9p2-j4hg-g373
References
Advisory 2
More Apache Cassandra vulnerabilities
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2021-20121 Remote code execution for scripted UDFs CVSS 3.1CRITICAL 9.1
- TI-2019-02233 Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent… CVSS 3.1MEDIUM 5.9
- TI-2018-05793 Missing authentication in Apache Cassandra CVSS 3.0CRITICAL 9.8
- TI-2016-04292 handler/ssl/OpenSslEngine.java in Netty 4.0.x before 4.0.37.Final and 4.1.x before… CVSS 3.1HIGH 7.5
- TI-2025-16827 Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions CVSS 3.1HIGH 8.8
Sources
- CVE-2023-30601 · CVE Program
- CVE-2023-30601 · NVD
- FIRST EPSS
- GHSA-m9p2-j4hg-g373 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences