Moodle: minor sql injection risk in external wiki method for listing pages
Priority LOW 34CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
The vulnerability was found Moodle which exists due to insufficient sanitization of user-supplied data in external Wiki method for listing pages. A remote attacker can send a specially crafted request to the affected application and execute limited SQL commands within the application database.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01142 66th percentileScored 2026-11-07
Fix Fixed moodle: 4.1.3, 4.0.8, 3.11.14 +1moodle/moodle (Packagist): 4.2.0-rc2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 4.1.0 to before 4.1.3; 4.0.0 to before 4.0.8; 3.11.0 to before 3.11.14; before 3.9.21 | 4.1.3, 4.0.8, 3.11.14, 3.9.21 | Patch available | CNA |
| — | moodle/moodle (Packagist) | before 4.2.0-rc2 | 4.2.0-rc2 | Patch available | GHSA-7mmc-22g7-3xq2 |
- moodle Vendor— Affected 4.1.0 to before 4.1.3; 4.0.0 to before 4.0.8; 3.11.0 to before 3.11.14; before 3.9.21 Fixed in 4.1.3, 4.0.8, 3.11.14, 3.9.21 Patch available CNA
- moodle/moodle (Packagist) Vendor— Affected before 4.2.0-rc2 Fixed in 4.2.0-rc2 Patch available GHSA-7mmc-22g7-3xq2
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | 3.9.0 to before 3.9.21; 3.11.0 to before 3.11.14; 4.0.0 to before 4.0.8; 4.1.0 to before 4.1.3 | Vulnerable | Moodle |
| cpe:2.3:a:fedoraproject:extra_packages_for_enterprise_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* | 36 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* | 37 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* | 38 | Vulnerable | Fedoraproject |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.9.0 to before 3.9.21; 3.11.0 to before 3.11.14; 4.0.0 to before 4.0.8; 4.1.0 to before 4.1.3 Vulnerable ·Moodle
- cpe:2.3:a:fedoraproject:extra_packages_for_enterprise_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* Versions 36 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* Versions 37 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* Versions 38 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA moodle Fixed in 4.1.3, 4.0.8, 3.11.14, 3.9.21
- Fix · GHSA-7mmc-22g7-3xq2 moodle/moodle (Packagist) Fixed in 4.2.0-rc2 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2023-30944
- 2026-10-03 Alias added: GHSA-7mmc-22g7-3xq2
References
Patch 3
Advisory 4
Other 8
- https://github.com/moodle/moodle/commit/5521d1d6e8bb8bebb76ad8154095f6b18ea26e7f
- https://github.com/moodle/moodle
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/54TM5H5PDUDYXOQ7X7PPYWP4AJDAE73I
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MZBWRVUJF7HI53XCJPJ3YJZPOV5HBRUY
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PBFSXRYLT4ICKJVQSRBAOUDMDRVSVBLS
- https://lists.fedoraproject.org/archives/list/[email protected]/message/54TM5H5PDUDYXOQ7X7PPYWP4AJDAE73I
- https://lists.fedoraproject.org/archives/list/[email protected]/message/MZBWRVUJF7HI53XCJPJ3YJZPOV5HBRUY
- https://lists.fedoraproject.org/archives/list/[email protected]/message/PBFSXRYLT4ICKJVQSRBAOUDMDRVSVBLS
Sources
- CVE-2023-30944 · CVE Program
- CVE-2023-30944 · NVD
- FIRST EPSS
- GHSA-7mmc-22g7-3xq2 · GitHub Advisory Database · CC BY 4.0
- CVE-2023-30944 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences