Read the docs
TI-2023-15535 Aliases CVE-2023-32237GHSA-m6h2-9w6w-xj46

Auth. Stored Cross-Site Scripting (XSS) vulnerability in TheGem theme by CodexThemes

Priority LOW 24CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CodexThemes TheGem (Elementor), CodexThemes TheGem (WPBakery) allows Stored XSS.This issue affects TheGem (Elementor): from n/a before 5.8.1.1; TheGem (WPBakery): from n/a before 5.8.1.1.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00357 29th percentileScored 2026-11-07
Fix Fixed TheGem (Elementor) (CodexThemes): 5.8.1.1TheGem (WPBakery) (CodexThemes): 5.8.1.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
CodexThemesTheGem (Elementor)before 5.8.1.15.8.1.1Patch availableCNA
CodexThemesTheGem (WPBakery)before 5.8.1.15.8.1.1Patch availableCNA
  • TheGem (Elementor) VendorCodexThemes Affected before 5.8.1.1 Fixed in 5.8.1.1 Patch available CNA
  • TheGem (WPBakery) VendorCodexThemes Affected before 5.8.1.1 Fixed in 5.8.1.1 Patch available CNA

Remediation

  • Fix · CNA TheGem (Elementor) (CodexThemes) Fixed in 5.8.1.1
  • Fix · CNA TheGem (WPBakery) (CodexThemes) Fixed in 5.8.1.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-32237
  2. 2026-10-03 Alias added: GHSA-m6h2-9w6w-xj46

References

  • TI-2026-47280 WordPress TheGem (Elementor) theme <= 5.12.3 - SQL Injection vulnerability CVSS 3.1CRITICAL 9.3
  • TI-2025-03846 TheGem <= 5.10.3 - Authenticated (Subscriber+) Arbitrary File Upload CVSS 3.1HIGH 8.8
  • TI-2025-38368 WordPress TheGem Theme Elements (for WPBakery) plugin <= 5.10.5.1 - Local File Inclusion vulnerability CVSS 3.1HIGH 8.1
  • TI-2026-41626 WordPress TheGem Theme Elements (for Elementor) plugin < 5.12.1.1 - Local File Inclusion vulnerability CVSS 3.1HIGH 7.5
  • TI-2025-42799 WordPress TheGem Theme Elements (for Elementor) plugin <= 5.11.0 - Local File Inclusion vulnerability CVSS 3.1HIGH 7.5
  • TI-2025-42081 WordPress TheGem Theme Elements (for Elementor) plugin <= 5.10.5.1 - Local File Inclusion vulnerability CVSS 3.1HIGH 7.5
See all 21 →

Sources