Read the docs

CodexThemes

Records22All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical1CVSS 9.0–10.0
CVSS high7CVSS 7.0–8.9

Exploited now

CodexThemes records in CISA KEV

No CodexThemes vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

22 records

Priority MEDIUM 42

The TheGem theme for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the thegem_get_logo_url() function in all versions up to, and including, 5.10.3.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.01184 Published 2025-05-13 No fix listed CWE-434
Priority LOW 38

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in CodexThemes TheGem Theme Elements (for WPBakery) thegem-elements.This issue affects TheGem Theme El…

CVSS 3.1HIGH 8.1 Network No auth No interaction EPSS 0.00537 Published 2025-11-06 No fix listed CWE-98
Priority LOW 35

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in CodexThemes TheGem Theme Elements (for Elementor) allows PHP Local File Inclusion.

CVSS 3.1HIGH 7.5 Network Low privileges No interaction EPSS 0.00511 Published 2026-07-13 Fixed in 5.12.1.1 CWE-98
Priority LOW 35

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in CodexThemes TheGem Theme Elements (for Elementor) thegem-elements-elementor allows PHP Local File I…

CVSS 3.1HIGH 7.5 Network Low privileges No interaction EPSS 0.0039 Published 2026-01-06 No fix listed CWE-98
Priority LOW 35

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in CodexThemes TheGem Theme Elements (for Elementor) thegem-elements-elementor.This issue affects TheG…

CVSS 3.1HIGH 7.5 Network Low privileges No interaction EPSS 0.00379 Published 2025-12-23 No fix listed CWE-98
Priority LOW 31

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CodexThemes TheGem - Creative Multi-Purpose & WooCommerce WordPress Theme allows Reflected XSS.This issue affects TheG…

CVSS 3.1HIGH 7.1 Network No auth User interaction EPSS 0.00343 Published 2023-12-29 No fix listed CWE-79
Priority LOW 30

Vulnerability in CodexThemes TheGem (Elementor), CodexThemes TheGem (WPBakery).This issue affects TheGem (Elementor): from n/a before 5.8.1.1; TheGem (WPBakery): from n/a before 5.8.1.1.

CVSS 3.1MEDIUM 5.4 Network Low privileges No interaction EPSS 0.002 Published 2025-12-29 Fixed in 5.8.1.1 CWE-284
Priority LOW 28

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CodexThemes TheGem Theme Elements (for Elementor) allows DOM-Based XSS.This issue affects TheGem Theme Elements (for E…

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.00127 Published 2026-04-27 Fixed in 5.12.1.1 CWE-79
Priority LOW 28

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CodexThemes TheGem Theme Elements (for WPBakery) thegem-elements allows DOM-Based XSS.This issue affects TheGem Theme…

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.00159 Published 2026-01-06 No fix listed CWE-79
Priority LOW 28

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CodexThemes TheGem Theme Elements (for Elementor) thegem-elements-elementor allows Stored XSS.This issue affects TheGe…

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.00159 Published 2026-01-06 No fix listed CWE-79
Priority LOW 28

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CodexThemes TheGem Theme Elements (for Elementor) thegem-elements-elementor.This issue affects TheGem Theme Elements (…

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.00159 Published 2025-12-23 No fix listed CWE-79
Priority LOW 28

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CodexThemes TheGem Theme Elements (for WPBakery) thegem-elements.This issue affects TheGem Theme Elements (for WPBaker…

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.00268 Published 2025-11-06 No fix listed CWE-79
Priority LOW 28

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CodexThemes TheGem thegem.This issue affects TheGem: from n/a through <= 5.10.5.

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.0021 Published 2025-11-06 No fix listed CWE-79
Priority LOW 24

Missing Authorization vulnerability in CodexThemes TheGem thegem allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects TheGem: from n/a through <= 5.10.5.

CVSS 3.1MEDIUM 5.4 Network Low privileges No interaction EPSS 0.00273 Published 2025-09-26 No fix listed CWE-862
Priority LOW 24

Missing Authorization vulnerability in CodexThemes TheGem (Elementor) thegem-elementor allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects TheGem (Elementor): from n/a through <= 5.…

CVSS 3.1MEDIUM 5.4 Network Low privileges No interaction EPSS 0.00273 Published 2025-09-26 No fix listed CWE-862
Priority LOW 24

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CodexThemes TheGem (Elementor), CodexThemes TheGem (WPBakery) allows Stored XSS.This issue affects TheGem (Elementor):…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00357 Published 2024-03-26 Fixed in 5.8.1.1 CWE-79
Open these records in search →