aiven-extras PostgreSQL Privilege Escalation Through Overloaded Search Path
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
aiven-extras is a PostgreSQL extension. Versions prior to 1.1.9 contain a privilege escalation vulnerability, allowing elevation to superuser inside PostgreSQL databases that use the aiven-extras package. The vulnerability leverages missing schema qualifiers on privileged functions called by the aiven-extras extension. A low privileged user can create objects that collide with existing function names, which will then be executed instead. Exploiting this vulnerability could allow a low privileged user to acquire `superuser` privileges, which would allow full, unrestricted access to all data and database functions. And could lead to arbitrary code execution or data access on the underlying host as the `postgres` user. The issue has been patched as of version 1.1.9.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Aiven-Open | aiven-extras | before 1.1.9 | 1.1.9 | Patch available | CNA |
- aiven-extras VendorAiven-Open Affected before 1.1.9 Fixed in 1.1.9 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:aiven:aiven:*:*:*:*:*:postgresql:*:* | before 1.1.9 | Vulnerable | Aiven-Open |
| cpe:2.3:a:postgresql:postgresql:*:*:*:*:*:*:*:* | 10.0 – 10.22; 11.0 – 11.7; 12.0 – 12.12; 13.0 – 13.8; 14.0 – 14.5 | Running on | PostgreSQL |
- cpe:2.3:a:aiven:aiven:*:*:*:*:*:postgresql:*:* Versions before 1.1.9 Vulnerable ·Aiven-Open
- cpe:2.3:a:postgresql:postgresql:*:*:*:*:*:*:*:* Versions 10.0 – 10.22; 11.0 – 11.7; 12.0 – 12.12; 13.0 – 13.8; 14.0 – 14.5 Running on ·PostgreSQL
Remediation
- Fix · CNA aiven-extras (aiven) Fixed in 1.1.9
Timeline
- 2026-10-02 Threatist record created from CVE-2023-32305
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences