WordPress WooCommerce Product Recommendations Plugin < 2.3.0 is vulnerable to Cross Site Request Forgery (CSRF)
Priority MEDIUM 40CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.
Summary
Cross-Site Request Forgery (CSRF) vulnerability in WooCommerce Product Recommendations plugin <= 2.3.0 versions.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00301 22nd percentileScored 2026-11-07
Fix Fixed Product Recommendations (WooCommerce): 2.3.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WooCommerce | Product Recommendations | before 2.3.0 | 2.3.0 | Patch available | CNA |
- Product Recommendations VendorWooCommerce Affected before 2.3.0 Fixed in 2.3.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:woocommerce:product_recommendations:*:*:*:*:*:wordpress:*:* | before 2.3.0 | Vulnerable | WooCommerce |
- cpe:2.3:a:woocommerce:product_recommendations:*:*:*:*:*:wordpress:*:* Versions before 2.3.0 Vulnerable ·WooCommerce
Remediation
- Fix · CNA Product Recommendations (WooCommerce) Fixed in 2.3.0
Timeline
- 2026-10-02 Threatist record created from CVE-2023-32744
- 2026-10-03 Alias added: GHSA-r25p-2jw3-4qp2
Sources
- CVE-2023-32744 · CVE Program
- CVE-2023-32744 · NVD
- FIRST EPSS
- GHSA-r25p-2jw3-4qp2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences