Network & Virtual Switch
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
A cross-site scripting (XSS) vulnerability has been reported to affect Network & Virtual Switch. If exploited, the vulnerability could allow authenticated administrators to inject malicious code via a network. We have already fixed the vulnerability in the following versions: QuTScloud c5.1.5.2651 and later QTS 5.1.4.2596 build 20231128 and later QuTS hero h5.1.4.2596 build 20231128 and later
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| QNAP | QuTScloud | c5.x.x to before c5.1.5.2651 | c5.1.5.2651 | Patch available | CNA |
| QNAP | QTS | 5.1.x to before 5.1.4.2596 build 20231128 | 5.1.4.2596 build 20231128 | Patch available | CNA |
| QNAP | QuTS hero | h5.1.x to before h5.1.4.2596 build 20231128 | h5.1.4.2596 build 20231128 | Patch available | CNA |
- QuTScloud VendorQNAP Affected c5.x.x to before c5.1.5.2651 Fixed in c5.1.5.2651 Patch available CNA
- QTS VendorQNAP Affected 5.1.x to before 5.1.4.2596 build 20231128 Fixed in 5.1.4.2596 build 20231128 Patch available CNA
- QuTS hero VendorQNAP Affected h5.1.x to before h5.1.4.2596 build 20231128 Fixed in h5.1.4.2596 build 20231128 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:qnap:qts:*:*:*:*:*:*:*:* | 5.1.0 to before 5.1.4.2596 | Vulnerable | QNAP |
| cpe:2.3:o:qnap:qts:5.1.4.2596:-:*:*:*:*:*:* | 5.1.4.2596 | Vulnerable | QNAP |
| cpe:2.3:o:qnap:quts_hero:*:*:*:*:*:*:*:* | h5.1.0 to before h5.1.4.2596 | Vulnerable | QNAP |
| cpe:2.3:o:qnap:quts_hero:h5.1.4.2596:-:*:*:*:*:*:* | h5.1.4.2596 | Vulnerable | QNAP |
| cpe:2.3:o:qnap:qutscloud:*:*:*:*:*:*:*:* | c5.0.0.1919 to before c5.1.5.2651 | Vulnerable | QNAP |
- cpe:2.3:o:qnap:qts:*:*:*:*:*:*:*:* Versions 5.1.0 to before 5.1.4.2596 Vulnerable ·QNAP
- cpe:2.3:o:qnap:qts:5.1.4.2596:-:*:*:*:*:*:* Versions 5.1.4.2596 Vulnerable ·QNAP
- cpe:2.3:o:qnap:quts_hero:*:*:*:*:*:*:*:* Versions h5.1.0 to before h5.1.4.2596 Vulnerable ·QNAP
- cpe:2.3:o:qnap:quts_hero:h5.1.4.2596:-:*:*:*:*:*:* Versions h5.1.4.2596 Vulnerable ·QNAP
- cpe:2.3:o:qnap:qutscloud:*:*:*:*:*:*:*:* Versions c5.0.0.1919 to before c5.1.5.2651 Vulnerable ·QNAP
Remediation
- Fix · CNA QuTScloud (QNAP Systems Inc.) Fixed in c5.1.5.2651
- Fix · CNA QTS (QNAP Systems Inc.) Fixed in 5.1.4.2596 build 20231128
- Fix · CNA QuTS hero (QNAP Systems Inc.) Fixed in h5.1.4.2596 build 20231128
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
QNAP Systems QuTScloud c5.1.5.2651
3 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2024-14559 Improper authentication in QNAP QTSPriority HIGH 70
- TI-2024-14560 Injection in QNAP QTSPriority MEDIUM 41
Timeline
- 2026-10-02 Threatist record created from CVE-2023-32969
- 2026-10-03 Alias added: GHSA-j32g-85qg-wf4w
References
More QNAP Qts vulnerabilities
- TI-2020-02221 Command Injection Vulnerability in QTS and QuTS hero KEVCVSS 3.1CRITICAL 9.8
- TI-2019-05101 Improper input validation in QNAP NAS devices KEVCVSS 3.1CRITICAL 9.8
- TI-2018-14137 Improper input validation in QNAP QTS KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05975 GNU Bash through 4.3 bash43-025 processes trailing strings after certain malformed… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05157 GNU Bash through 4.3 processes trailing strings after function definitions in the values… KEVCVSS 3.1CRITICAL 9.8
- TI-2018-14131 Cross-site scripting in QNAP QTS KEVCVSS 3.1HIGH 8.0
Sources
- CVE-2023-32969 · CVE Program
- CVE-2023-32969 · NVD
- FIRST EPSS
- GHSA-j32g-85qg-wf4w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences