Snowflake NodeJS Driver vulnerable to Command Injection
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-77.
Summary
snowflake-connector-nodejs, a NodeJS driver for Snowflake, is vulnerable to command injection via single sign on (SSO) browser URL authentication in versions prior to 1.6.21. In order to exploit the potential for command injection, an attacker would need to be successful in (1) establishing a malicious resource and (2) redirecting users to utilize the resource. The attacker could set up a malicious, publicly accessible server which responds to the SSO URL with an attack payload. If the attacker then tricked a user into visiting the maliciously crafted connection URL, the user’s local machine would render the malicious payload, leading to a remote code execution. This attack scenario can be mitigated through URL whitelisting as well as common anti-phishing resources. Version 1.6.21 contains a patch for this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Snowflake | snowflake-connector-nodejs | before 1.6.21 | 1.6.21 | Patch available | CNA |
| — | snowflake-sdk (npm) | before 1.6.21 | 1.6.21 | Patch available | GHSA-h53w-7qw7-vh5c |
- snowflake-connector-nodejs VendorSnowflake Affected before 1.6.21 Fixed in 1.6.21 Patch available CNA
- snowflake-sdk (npm) Vendor— Affected before 1.6.21 Fixed in 1.6.21 Patch available GHSA-h53w-7qw7-vh5c
Remediation
- Fix · CNA snowflake-connector-nodejs (snowflakedb) Fixed in 1.6.21
- Fix · GHSA-h53w-7qw7-vh5c snowflake-sdk (npm) Fixed in 1.6.21 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-34232
- 2026-10-03 Alias added: GHSA-h53w-7qw7-vh5c
References
Patch 2
Advisory 2
More Snowflake Connector vulnerabilities
- TI-2022-20945 Exponential ReDoS in snowflake-connector-python leads to denial of service CVSS 3.1HIGH 7.5
- TI-2023-17069 Snowflake Python Connector vulnerable to Command Injection CVSS 3.1HIGH 8.8
- TI-2023-17066 Snowflake Connector vulnerable to Command Injection CVSS 3.1HIGH 8.8
- TI-2025-18511 The Snowflake Connector for Python uses insecure deserialization of the OCSP response cache CVSS 3.1HIGH 7.8
- TI-2025-18510 Snowflake Connector for Python has an SQL Injection in write_pandas CVSS 3.1HIGH 7.0
- TI-2023-28309 Snowflake Connector .NET does not properly check the Certificate Revocation List (CRL) CVSS 3.1HIGH 7.5
Sources
- CVE-2023-34232 · CVE Program
- CVE-2023-34232 · NVD
- FIRST EPSS
- GHSA-h53w-7qw7-vh5c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences