Snowflake Connector for Python has an SQL Injection in write_pandas
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
The Snowflake Connector for Python provides an interface for developing Python applications that can connect to Snowflake and perform all standard operations. Snowflake discovered and remediated a vulnerability in the Snowflake Connector for Python. A function from the snowflake.connector.pandas_tools module is vulnerable to SQL injection. This vulnerability affects versions 2.2.5 through 3.13.0. Snowflake fixed the issue in version 3.13.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Snowflake | snowflake-connector-python | 2.2.5 to before 3.13.1 | 3.13.1 | Patch available | CNA |
| — | snowflake-connector-python (PyPI) | 2.2.5 to before 3.13.1 | 3.13.1 | Patch available | GHSA-2vpq-fh52-j3wv |
- snowflake-connector-python VendorSnowflake Affected 2.2.5 to before 3.13.1 Fixed in 3.13.1 Patch available CNA
- snowflake-connector-python (PyPI) Vendor— Affected 2.2.5 to before 3.13.1 Fixed in 3.13.1 Patch available GHSA-2vpq-fh52-j3wv
Remediation
- Fix · CNA snowflake-connector-python (snowflakedb) Fixed in 3.13.1
- Fix · GHSA-2vpq-fh52-j3wv snowflake-connector-python (PyPI) Fixed in 3.13.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-24793
- 2026-10-03 Alias added: GHSA-2vpq-fh52-j3wv
References
Advisory 2
More Snowflake Connector vulnerabilities
- TI-2022-20945 Exponential ReDoS in snowflake-connector-python leads to denial of service CVSS 3.1HIGH 7.5
- TI-2023-17069 Snowflake Python Connector vulnerable to Command Injection CVSS 3.1HIGH 8.8
- TI-2023-17068 Snowflake NodeJS Driver vulnerable to Command Injection CVSS 3.1HIGH 8.8
- TI-2023-17066 Snowflake Connector vulnerable to Command Injection CVSS 3.1HIGH 8.8
- TI-2025-18511 The Snowflake Connector for Python uses insecure deserialization of the OCSP response cache CVSS 3.1HIGH 7.8
- TI-2023-28309 Snowflake Connector .NET does not properly check the Certificate Revocation List (CRL) CVSS 3.1HIGH 7.5
Sources
- CVE-2025-24793 · CVE Program
- CVE-2025-24793 · NVD
- FIRST EPSS
- GHSA-2vpq-fh52-j3wv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences